Highlighted

Nodes are not created after uploading and installing package

divyanshuk26109

22-06-2019

Hi,

I am new to AEM and learning to create multifield component in AEM 6.3 using sling models.

I went through the following article Creating a Granite/Coral 6.3 Multifield HTL component for Adobe Experience Manager.

I have downloade the package given there. I have uploade and installed the package using package manager but nodes are not created under apps. I am nt able to see the mfCoral63 node under apps after installing the package.

Please help me on this.

Thanks

Replies

Highlighted

hamidk92094312

Employee

24-06-2019

I verified the following packages are created in CRX/DE upon uploading the package:

/etc/designs/mfCoral63

/apps/mfCoral63

/content/mfCoral63

/content/dam/mfCoral63

- What version of AEM are you running ?

- Do you see any error in the "error.log" related to uploading the package ?

Highlighted

divyanshuk26109

25-06-2019

Hi Hamid,

1. AEM Version is 6.3.0

2. There is no error logged. Below is the activity log:

Build Package: /etc/packages/mfCoral63/mfCoral63.ui.apps-1.0-SNAPSHOT.zip

Tue Jun 25 2019 23:32:39 GMT+0530 (India Standard Time)

Building package

A META-INF

A META-INF/vault
A META-INF/vault/config.xml
A META-INF/vault/filter.xml
A META-INF/vault/nodetypes.cnd
A META-INF/vault/properties.xml
A /.content.xml
A /etc
A /etc/.content.xml
A /etc/designs
A /etc/designs/.content.xml
A /content
A /content/.content.xml
A /content/dam
A /content/dam/.content.xml
A /apps
A /apps/.content.xml
- Aggregation status: 5 of 0 prepared, 2 collected
A META-INF/vault/definition/.content.xml
A META-INF/vault/definition/thumbnail.png

Package built in 490ms.


Install Package: /etc/packages/mfCoral63/mfCoral63.ui.apps-1.0-SNAPSHOT.zip

Tue Jun 25 2019 23:33:04 GMT+0530 (India Standard Time)

Installing content

Creating snapshot for package mfCoral63:mfCoral63.ui.apps:1.0-SNAPSHOT

A META-INF
A META-INF/vault
A META-INF/vault/config.xml
A META-INF/vault/filter.xml
A META-INF/vault/nodetypes.cnd
A META-INF/vault/properties.xml
A /.content.xml
A /etc
A /etc/.content.xml
A /etc/designs
A /etc/designs/.content.xml
A /content
A /content/.content.xml
A /content/dam
A /content/dam/.content.xml
A /apps
A /apps/.content.xml
- Aggregation status: 5 of 0 prepared, 2 collected
A META-INF/vault/definition/.content.xml
Collecting import information...
Installing node types...

- rep -> internal
- nt -> http://www.jcp.org/jcr/nt/1.0
- sling -> http://sling.apache.org/jcr/sling/1.0
- sling:Folder
- sling:OrderedFolder
- rep:RepoAccessControllable
Installing privileges...
Importing content...
- /
- /etc
- /etc/designs
- /apps
- /content
- /content/dam
saving approx 0 nodes...
Package imported.

Package installed in 1323ms.

I tried to install it again but still nodes are not appearing.

crx_de_screenshot.PNG

Highlighted

SonDang

Employee

25-06-2019

Several things to try.

1. Verify that you download from https://helpx.adobe.com/content/dam/help/en/experience-manager/using/multifield_coral_aem63/_jcr_con...

2b. If you run md5 hash on the file, what is the value? Below is what I got back from the package

MD5 (mfcoral63_ui_apps-10-snapshot1.zip) = 170603ae357b43420a3da0db96263d8f

2b. Try to unzip the package to see if the content you are missing is actually in the package.

3. If you are not using the admin account to install the package, please use admin account.