No popup showing for unpublished experience fragments when added on page

Avatar

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
surabhid2471036
Level 1

11-09-2018

Hi,

For our project requirement we need to overlay experience fragment(/libs/cq/experience-fragments/editor/components/experiencefragment) component. Now when we add this experience fragment component on the page and author experience fragment variation path which is not published, it should open a popup which displays the fragment which are not published same as dam assets when referred on the page(as shown in below screenshot). But in our case, page is published without popup.

popup.png

Any pointers would be helpful.

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

11-09-2018

What code changes have you tried. Can you post the starting point of the changes you have implemented so community can suggest how best to implement. This is a very specific customization (without any docs) and in order for members to understand what you are trying to do - the code should be posted too.

Avatar

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
surabhid2471036
Level 1

11-09-2018

We have copied the experiencefragment component from /libs/cq/experience-fragments/editor/components/experiencefragment

and pasted it in our project specific folder. And in experiencefragment.html removed highlighted piece of code.

<sly data-sly-test=${data.fragmentPath}

         data-sly-resource="${@path=data.fragmentPath, selectors='content', wcmmode='disabled'}"></sly>

Avatar

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
surabhid2471036
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
surabhid2471036
Level 1

11-09-2018

Also tried not doing any code changes in experiencefragment.html. Just copy pasted component in our project. Still it didn't work.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

13-09-2018

I looked for examples here that can help - but could not find any. THis is not a common use case - that is the reason why there are no examples.