Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

My PDFs thumbnail image does not render when uploading

Avatar

Level 1

I am trying to upload a PDF with an image on the cover but for some reason when it hits the AEM my thumbnail does not render properly.

I have no knowledge about AEM so I would like to know if I am doing anything wrong?

Note: my images are rastered, only 161 kb in size, and set up as RGB for digital.

Screenshot 2023-03-03 at 4.59.29 AM.pngScreenshot 2023-03-03 at 4.58.11 AM.png

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @RQ30 ,

There are a couple of ways to do it-

1. Can you check in the content tree whether your content is getting saved or not?

2. If not, then please try to check the sightly code and name of the image field. also, getter of sling models.

3. Check in DOM elements, if the image URL is getting rendered there.

4. If you are checking on publish, then make sure the image the published as well.

 

Thanks

View solution in original post

1 Reply

Avatar

Correct answer by
Community Advisor

Hi @RQ30 ,

There are a couple of ways to do it-

1. Can you check in the content tree whether your content is getting saved or not?

2. If not, then please try to check the sightly code and name of the image field. also, getter of sling models.

3. Check in DOM elements, if the image URL is getting rendered there.

4. If you are checking on publish, then make sure the image the published as well.

 

Thanks