Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

javax.inject,version=[0.0,1) — Cannot be resolved

Var
Level 5
Level 5

Is there any other work around to fix the javax.inject,version=[0.0,1) -- Cannot be resolvedissue in OSGI bundle.

I have tried all the approaches provided in the below forum. but still my bundle doesn't resolve.

I am using AEM 6.2 + Java version: 1.8.0_121 + Apache Maven 3.3.9 and archetypeVersion=10 

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

The POC code snippet can be found in my drive here

1 Accepted Solution
Feike_Visser1
Correct answer by
Employee
Employee

add this dependency:

        <dependency>

            <groupId>javax.inject</groupId>

            <artifactId>javax.inject</artifactId>

            <version>1</version>

            <scope>provided</scope>

        </dependency>

View solution in original post

6 Replies
vjetty
Level 4
Level 4

Hi, Try these dependencies.

<dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.api</artifactId> <version>1.2.2</version> <scope>provided</scope> </dependency> <dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.impl</artifactId> <version>1.2.2</version> <scope>provided</scope> </dependency> <dependency> <groupId>org.apache.geronimo.specs</groupId> <artifactId>geronimo-atinject_1.0_spec</artifactId> <version>1.0</version> <scope>provided</scope> </dependency>

And also check the required uber-jar is present.

<dependency> <groupId>com.adobe.aem</groupId> <artifactId>uber-jar</artifactId> <version>6.2.0</version> <classifier>apis</classifier> <scope>provided</scope> </dependency>

Hope this helps!

Thanks,

Vamsi

Feike_Visser1
Correct answer by
Employee
Employee

add this dependency:

        <dependency>

            <groupId>javax.inject</groupId>

            <artifactId>javax.inject</artifactId>

            <version>1</version>

            <scope>provided</scope>

        </dependency>

View solution in original post

Prince_Shivhare
Community Advisor
Community Advisor

Hi,

This issue is only in AEM 6.2 once you create or deploy new project. you need to add the below dependency in your core project:

<dependency> <groupId>javax.inject</groupId> <artifactId>javax.inject</artifactId> <version>1</version> </dependency>

AEM versions prior to 6.2, there was a dependency to javax.inject version 0 whereas now they need version 1 and that's not reflected in the pom.xml.

 

~ Prince

Var
Level 5
Level 5

Feike Visser wrote...

add this dependency:

        <dependency>

            <groupId>javax.inject</groupId>

            <artifactId>javax.inject</artifactId>

            <version>1</version>

            <scope>provided</scope>

        </dependency>

 

Thanks Feike,

after so many rebuilds with modification of pom files finally found it works with

<dependency><groupId>org.apache.sling</groupId><artifactId>o‌​rg.apache.sling.mode‌​ls.api</artifactId><‌​/dependency> <dependency> <groupId>org.apache.sling</groupId> <artifactId>org.apache.sling.models.impl</artifactId> </dependency> <dependency> <groupId>javax.inject</groupId> <artifactId>javax.inject</artifactId> </dependency>

 as mandatory in build and remaining uber-jar and geronimo-atinject_1.0_spec jars as optional. even both together works.

AasishJain
Level 1
Level 1
Spoiler
 

add this dependency in your core/pom.xml

Screenshot 2021-02-19 at 8.35.17 AM.png