Issue with pages appending "/" at the end

Avatar

Avatar

bunny87948290

Avatar

bunny87948290

bunny87948290

13-03-2018

Hello,

We are seeing issue with our site for some pages. Welcome to Interflex  When you go to New and Events page from navigation, it opens the page appending   "/" at the end. After we clear the dispatcher cache, page loads fine for some time. Again, it starts appending "/". Is it considering it as a directory and appending that "/" ? What can be done to fix this issue. Will appreciate your response on this.

Thanks.

Replies

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

13-03-2018

When you create your Nav component - are you not specifying the URL to open the page?

For example - look here at how we developed the Nav component. There should be no /appended:

Adobe Experience Manager Help | Creating your First Adobe Experience Manager 6.3 website

Avatar

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K
Jörg_Hoh
Employee

13-03-2018

sounds like an issue with the dispatcher cache; the most typical error case is that

/opt/cache/docroot/news-and-events

cannot be a directory and a file at the same time. This might cause issues. On the other hand side what kind of URLs are you creating? How do they look like?

Jörg

Avatar

Avatar

bunny87948290

Avatar

bunny87948290

bunny87948290

13-03-2018

Yes, it is dispatcher cache issue but it comes up often.

There is a page new-and-envents.html that is what we are trying to access.

Regarding URL - we have - /content/interflex/en/news-and-events.html page created and we are trying to access this page from our website  - News and Events

This seems to load fine now. But it doesn't stay that way. It goes blank and it is because it appends  "/" at the end when you try to access this page url.

Avatar

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

996

Correct Reply

1.0K
Jörg_Hoh
Employee

13-03-2018

Hi,

when this situation happens again, can you share these details:

  • What are the details of the dispatcher cache structure (that means, what directories and files do exist, plus the structure of them).
  • Webserver logs, dispatcher logs (preferable at loglevel debug), AEM request.logs for these requests

Jörg