Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Issue with AEM 6.5.9 and 6.5.9 service pack

VineetPandey
Level 1
Level 1

Hi All,

 I have come across a scenario such as I am trying to access below url on fresh 6.5 instance and it works fine.

http://localhost:4502/editor.html/content/we-retail/language-masters/en..html

 

Now I am installing 6.5.9 service pack and the same url is throwing 400 bad Request .

 

Note: URL contains "..html". Ideally it should be considered as selector with null or empty value I guess.

 

Any help will be appreciated.

1 Accepted Solution
Rajashankar
Correct answer by
Level 4
Level 4

Hi @VineetPandey 

I too tested your scenario in 6.5 it works even though its null selector whereas in 6.5.9 it is considering the entire url as suffix and throwing a malformed url exception.

G Resource Path Info: SlingRequestPathInfo: path='/libs/cq/gui/content/editor', selectorString='null', extension='html', suffix='/content/we-retail/language-masters/en..html'

 

View solution in original post

1 Reply
Rajashankar
Correct answer by
Level 4
Level 4

Hi @VineetPandey 

I too tested your scenario in 6.5 it works even though its null selector whereas in 6.5.9 it is considering the entire url as suffix and throwing a malformed url exception.

G Resource Path Info: SlingRequestPathInfo: path='/libs/cq/gui/content/editor', selectorString='null', extension='html', suffix='/content/we-retail/language-masters/en..html'

 

View solution in original post