Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Issue While Integrating Remote Solr with AEM 6.0

Avatar

Level 3

I am trying to integrate remote SOLR 4.10.2, with AEM 6.0(SP1). But, while trying to integrate it, my AEM instance is throwing error and not at all coming up. I am attaching the  the configuration files of SOLR in txt format, which I placed. PFB the error:

org.apache.solr.client.solrj.impl.HttpSolrServer$RemoteSolrException: Expected mime type application/octet-stream but got text/html. <html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
<title>Error 404 Not Found</title>
</head>
<body><h2>HTTP ERROR 404</h2>
<p>Problem accessing /solr/admin/ping. Reason:
<pre>    Not Found</pre></p><hr /><i><small>Powered by Jetty://</small></i><br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                
<br/>                                                

</body>
</html>

    at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:459)
    at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:199)
    at org.apache.solr.client.solrj.request.SolrPing.process(SolrPing.java:70)
    at org.apache.solr.client.solrj.SolrServer.ping(SolrServer.java:293)
    at org.apache.jackrabbit.oak.plugins.index.solr.server.RemoteSolrServerProvider.initializeWithExistingHttpServer(RemoteSolrServerProvider.java:75)
    at org.apache.jackrabbit.oak.plugins.index.solr.server.RemoteSolrServerProvider.getSolrServer(RemoteSolrServerProvider.java:61)

1 Accepted Solution

Avatar

Correct answer by
Level 10
2 Replies

Avatar

Correct answer by
Level 10

Looks like a bug - please file a ticket here:

http://helpx.adobe.com/marketing-cloud/experience-manager.html

Avatar

Level 1

Hi,

Any Updates on this topic?

I am also facing the same issue.

 

Regards,

Anurag Datta