Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

iFrame in Rich Text Editor

Avatar

Avatar
Level 1
nevs81819115
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
nevs81819115
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
nevs81819115
Level 1

30-09-2017

Hi Community,

I'm trying to add an iframe via rich text editor (RTE). It works whilst in edit mode but after I click save it no longer appears because the src attribute has been stripped from the iframe element. I guess this means the RTE does not support iframe by default. Is this correct? If so can the RTE be configured to support iframe?

Many thanks in advance.

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

02-10-2017

I do not think this is supported - i am double checking.

I am not clear why you would even want an iframe for a RTE.

Avatar

Avatar
Level 1
vikaaS
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
vikaaS
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
vikaaS
Level 1

31-05-2018

escapeXml="true" - is not allowing it.

if you override it with

escapeXml="false" and check

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

31-05-2018

The RTE in the COre components - like the Text component works perfectly fine.

Avatar

Avatar
Validate 1
Level 2
iainc65537558
Level 2

Likes

4 likes

Total Posts

35 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Validate 1
Level 2
iainc65537558
Level 2

Likes

4 likes

Total Posts

35 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
iainc65537558
Level 2

18-06-2018

Hi,

Just to clarify, are you saying that using the Core text component it is possible to include an iframe where the src attribute is not removed?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

18-06-2018

As i asked in the thread last year - why do you want to override the RTE by using an IFRAME. The RTE works fine as is.

Avatar

Avatar
Ignite 1
Level 2
Rajashankar
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Ignite 1
Validate 1
Give Back 3
Give Back
Boost 5
View profile

Avatar
Ignite 1
Level 2
Rajashankar
Level 2

Likes

5 likes

Total Posts

22 posts

Correct Reply

2 solutions
Top badges earned
Ignite 1
Validate 1
Give Back 3
Give Back
Boost 5
View profile
Rajashankar
Level 2

11-06-2020

Hi Mac,

I am slo getting same issue with RTE component 

I added below text in RTE:

<p><iframe width="560" height="315" src="https://www.youtube.com/embed/pQf4qIju0_E"></iframe></p>
<p><iframe width="560" height="315" src="https://player.vimeo.com/video/33698814"></iframe></p>

 

Now when i exit the edit mode and preview in page its showing only youtuve whereas vimeo or anyother player its not showing up.Its cleaning it up automatically as shown below.

<p><iframe width="560" height="315" src="https://www.youtube.com/embed/pQf4qIju0_E">&amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;...>
<p><iframe width="560" height="315">&amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;amp;nbsp;</iframe></p>