Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

I have no idea how I can test video resolution and video bitrate on dispatcher.

Avatar

Level 4

Hello Everyone.

I have the following requirement.

what is size resolution that is best for what internet speeds?

I have already configured dispatcher environment with Apache server.

I have to test on dispatcher below one case by case.

1599252_pastedImage_0.png

I have no idea how I can test video resolution and video bitrate on dispatcher.
1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Dear Chung,

Chrome has OOTB option to set custom download speed.[0], you could also use tools like Charles proxy to do similar.

[0] Network Analysis Reference  |  Tools for Web Developers  |  Google Developers

Most of the modern video providers already have options to serve content based on user download speed, e.g. they request the bitrate depending on the users speed.

Regards,

Peter

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

Dear Chung,

Chrome has OOTB option to set custom download speed.[0], you could also use tools like Charles proxy to do similar.

[0] Network Analysis Reference  |  Tools for Web Developers  |  Google Developers

Most of the modern video providers already have options to serve content based on user download speed, e.g. they request the bitrate depending on the users speed.

Regards,

Peter

Avatar

Level 10

Have you tested your videos on AEM pages that are not cached. If you select a tool as Peter suggests - you should be able to test the videos on Cached pages.

Avatar

Level 4

I want to test video resolution and internet speed on cached page.

and Can I set different video resolutions as I can set custom download speed using chrome developer tools?

And I have second question.

I have added video(AEM front end testing(HD1080P).mp4) file like below one and published it in author environment.

(http://localhost:4502/editor.html/content/rccexcaliburpoc/test.html)

1599277_pastedImage_1.png

But the video doesn't display like below one in publish environment.

(http://localhost:4503/content/rccexcaliburpoc/test.html)

1599305_pastedImage_2.png

I don't know why.

Avatar

Community Advisor

Please replicate video to publish environment and check, if still not appearing then clear cache and try.