Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

HTTP ERROR 404 Not Found

Avatar

Level 1

Hi Everyone,

I upgraded my instance version to aem-sdk-2023.12.14697.20231215T125030Z-231200. I'm not able to start the for the second time. For the first time, I'm able to start the instance and work on it. I always stop the instance with Ctrl+c. But when I try to start, I will get 404 error 

KeerthiDundi_0-1710866741892.png

Sometimes, it will take 30 to 45mins to start the instance but other than it will never start and the 404 persist.. I'm trying to start my instance using "java -Xdebug -Xmx2048M -agentlib:jdwp=transport=dt_socket,address=8888,server=y,suspend=n -jar aem-author-p4502.jar"(Debug Mode). Please let me know if I need to change the command or approach to start my instance. Thank you.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Level 10

@KeerthiDundi 

You need to wait for this to get get completed. First time it could take 5-10 minutes as well.

 

And

 

Use this command :

 

java -Xms4096m -Xmx4096m -XX:MaxPermSize=512m -jar AEM_6.3_Quickstart.jar -nofork [If your command is not working, use MAX RAM size]

 

Reference Must read posts:-

 

insufficent heap memory error with cq6-author-4502.jar on 8GB RAM physical machine.

View solution in original post

4 Replies

Avatar

Correct answer by
Level 10

@KeerthiDundi 

You need to wait for this to get get completed. First time it could take 5-10 minutes as well.

 

And

 

Use this command :

 

java -Xms4096m -Xmx4096m -XX:MaxPermSize=512m -jar AEM_6.3_Quickstart.jar -nofork [If your command is not working, use MAX RAM size]

 

Reference Must read posts:-

 

insufficent heap memory error with cq6-author-4502.jar on 8GB RAM physical machine.

Avatar

Level 1

Hi @Imran__Khan 

I am still facing this issue if I restart my system and start my jar file using this command, but it shows 404 not found. Is there any other solution for this issue?

Thanks in advance!

Avatar

Level 1

My team ran into a similar issue and the proposed solution did not help.

That said, my team did observe was the more recent versions of the AEM SDK are very sensitive to being shutdown aggressively. In our case, we make use of docker containers for running AEM for localhost development and the OOTB docker grace period for shutdown of a container is 10 seconds.  That 10 second shutdown window was closing before the AEM jar had shutdown gracefully which lead to repository corruption and the AEM jar treating the subsequent start up as an install and not a restart scenario.

To fix this, we extended the stop_grace_period to 3 minutes via our compose config; not that we need 3 minutes total, we're just provided ample time for the AEM jar to shutdown gracefully.