Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Getting started with SPA Editor - Issue with Chapter 1

samr99530769
Level 3
Level 3

HI Team

Am trying to integrate AEM and React SPA editor based on the steps provided in the below

Adobe Experience Manager Help | Getting Started with the AEM SPA Editor - Chapter 1


Chapter 0 - Able to complete all primary development setup and able to see the desired result in AEM local

Chapter 1 - Have followed the same steps and deployed the code to AEM 6.4 local . When I tried to open the sample page am getting the error as below .

I have also tried with installing the package they have provided , but still the same issue.

react-app.js:1 Uncaught (in promise) SyntaxError: Unexpected token < in JSON at position 0

    at react-app.js:1

Am not able to complete this chapter because of this issue . Can anyone advise on this

10 Replies
smacdonald2008
Level 10
Level 10

At the end of this - you will see packages for Chapter 1- please try installing them and see if you have same issue.

samr99530769
Level 3
Level 3

Hi Scott,

I have tried to do the same ,but still we are facing the same .

I guess the same issue is happening for couple of others too . Please see the below link for issue that i have created in GIT HUB

JSON exception on the pages - After completing Chapter 1 · Issue #19 · Adobe-Marketing-Cloud/aem-gui...

Peter_Puzanovs
Community Advisor
Community Advisor

samr99530769​​ just turn off authentication completely on your author instance and keep on with the tutorial.

Regards,

Peter

samr99530769
Level 3
Level 3

Hi PuzanovsP Sure i will turn off authentication. Can you please let me know if it is bug that needed fix on the tutorial been shared or the problem with SPA Editor shipped with 6.4 .

Peter_Puzanovs
Community Advisor
Community Advisor

Dear Sir or Madam,

Would expect a hotfix in next release hopefully. No, I'm not aware of any issue. May be DayCare has account of it.

Regards,

Peter

smacdonald2008
Level 10
Level 10

Danial and I were talking today about this. Neither one can reproduce this. Can you try on a fresh 6.4 instance and install the packages and see if you get this on a fresh instance.

smacdonald2008
Level 10
Level 10

I am also going through this again to ensure i do not encounter this issue. I will post back.

smacdonald2008
Level 10
Level 10

I went through section 1 and got this result...

SP1.png

In your AEM instance - did you install AEM 6.2 SP2?

smacdonald2008
Level 10
Level 10

As mentioned earlier - you can install these packages from end of section 1.

SP2.png