Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Follow dropdown options are not displayed in Reply Toolbar

Avatar

Level 2

I am trying add subscription component i.e. Follow button in reply's toolbar (inside Forum post). 

The Follow button should come before cancel and reply button in case of reply to a reply of a Post.

The follow button appears, but it does not display any options in it. Upon js debug, we found that the this variable has only id element and does not contain types, state etc., 

Steps followed:

  1. Extended the comments/comment component and customized the toolbar template to include the subscription component resourceType.

{{include this.id path="subscriptions" resourceType="/apps/test/components/subscriptions"}}

    2.Modified the custom Post component hbs file to include the custom toolbar template instead of OOTB toolbar.

{{include this resourceType='/apps/test/components/comments/comment' template="toolbar"}}

Please let us know if we are missing anything.

8 Replies

Avatar

Level 10

Are you working on AEM Communities

Avatar

Level 2

Hi smacdonald2008

Yes, I am working on AEM social communities Forum component.

I have to make Follow button appear beside the 'cancel' and 'Reply' button that is displayed when I do a reply to a reply on the Post.

One observation related to the issue is that in browser network calls, I see 404 Not Found response is obtained for

http://localhost:4502/content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr:content/co...

Please suggest how to fix this issue.

Avatar

Level 2

snbaemkautuksahniaponnusa

I was going through Communities Comment component , is it something that I am missing on including 'subscriptions' component

{{include this.id path="subscriptions" resourceType="/apps/test/components/subscriptions"}}

in the template toolbar

{{include this resourceType='/apps/test/components/comments/comment' template="toolbar"}}

In browser network calls, I see that 404 Not Found response is obtained for

http://localhost:4502/content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr:content/co...

Avatar

Community Advisor

Do you see "subscriptions" folder at "/content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr: content/content/primary/forum/xsas-EsSS/test1-VwNq/subscriptions" ?

Or does ""content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr: content/content/primary/forum/xsas-EsSS/test1-VwNq" exist?

That should get created when you add a forum post and then a comment on it I guess

content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr: content/content/primary/forum/xsas-EsSS/test1-VwNq/subscriptions

Avatar

Level 2

Hi snbaem​,

The reply to a post "content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr: content/content/primary/forum/xsas-EsSS/test1-VwNq" exists.

However, the "subscriptions" folder at "/content/usergenerated/asi/jcr/content/sites/soco/en/groups/test/jcr: content/content/primary/forum/xsas-EsSS/test1-VwNq/subscriptions" is not created.

Please let me know how do I get the folder created and resolve the issue.

Avatar

Level 10

This could be a bug. If you are unable to fix - i recommend opening a support ticket.

Avatar

Community Advisor

I think the folder should get created automatically OOTB (cannot tell what class does that). As Scott mentioned, this might be a candidate for support ticket. Meanwhile you can add the "subscriptions" folder node manually. But it may or may not need a sling:resourceType property and value I am unsure.

Avatar

Community Advisor

Try the "subscriptions" node as jcr:primaryType = oak:Unstructured and add property sling:resourceType = social/subscriptions/components/hbs/subscriptions with type=String