Experience Manager - Assessing the Upgrade Complexity with the Pattern Detector | AEM Community Discussion

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,201 likes

Total Posts

6,395 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,201 likes

Total Posts

6,395 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

10-05-2020

BlogImage.jpg

Experience Manager - Assessing the Upgrade Complexity with the Pattern Detector by Adobe Docs

Abstract

Overview
This feature allows you to check existing AEM instances for their upgradability by detecting patterns in use that:
1. Violate certain rules and are done in areas that will be affected or overwritten by the upgrade
2. Use an AEM 6.x feature or an API that is not backwards compatible on AEM 6.4 and can potentially break after upgrade.

This could serve as an assessment of the development effort that is involved in upgrading to AEM 6.4.

How to Set Up
The Pattern Detector is released separately as a one package working on any source AEM versions from 6.1 to 6.5 targeting AEM 6.5 upgrade. It can be installed using the Package Manager .

Read Full Blog

Experience Manager - Assessing the Upgrade Complexity with the Pattern Detector

Q&A

Please use this thread to ask the related questions.