Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Existing Pages created in AEM 6.0 NOT working as expected in AEM 6.1 - PageInfo.json throwing null pointer exception

Avatar

Level 2

hi Team,

Our project was running on AEM 6.0 where we created our existing pages. After upgrading to AEM 6.1, we installed the existing pages using package manager. All our components/templates/clientlibs got installed perfectly. 

But when we try to open the new page and drag/drop new components from sidekick, first of all no components are showing in sidekick and when we try to add using design mode, page gives internal server error in console. Please suggest.

http://localhost:4502/libs/wcm/core/content/pageinfo.json - > throws null pointer exception

1 Accepted Solution

Avatar

Correct answer by
Level 2

Thanks Everyone for replying.

I got it fixed. It was indeed problem with jcr:content only. It was available in our pages but was missing in the parent pages of the hierarchy. I just added the same and it started working. 🙂

View solution in original post

7 Replies

Avatar

Administrator

Can you check if this page has "jcr:content" node?

~kautuk

Avatar

Level 5

Do you have the custom parsys component inside your /apps project ? if yes, then you need to make some corrections in the parsys component code to see the components in the sidekick. There are some changes in Out of box parsys between AEM6.0 and AEM6.1. Can you please verify in geometrixx if same issues exists also there, if not, then you need to make some changes in your template and component code.

Also, you probably need to make some changes in the components dialog hierarchy to make it compatible working with AEM6.1. Sounds like, good amount of work

Avatar

Level 2

Yes Sandeep. It must be our project component/template specific problem because Geometrixx works absolutely fine. Also, we don't have custom parsys inside our project.

Could you please help with what kind of changes are you suggesting for parsys ? The sidekick is the problem, as components doesnt show up in the sidekick even the component group is checked in design mode. Request your expertise in the same.

Thanks

Abhijit

Avatar

Level 2

Yes Katuk, we do have a jcr:content node for our pages. The sidekick is the problem, as components doesnt show up in the sidekick even the component group is checked in design mode. 

Avatar

Level 9

Hi Abhijit,

There are souple of scenario encountered this issu. Basically The error indicates there is orphaned user exists OR some of resource components not started Or Content had wrong cloud config. My advise would be to engage with official support team.  If you have patience & able to share below information. Community can try to help you. Please send

1) Output of view-source:http://host:port/system/console/components

2)  Output of all log files.

3)   Download the package and send output as mentioned in https://github.com/Adobe-Consulting-Services/acs-aem-tools/issues/177

Thanks,

Avatar

Correct answer by
Level 2

Thanks Everyone for replying.

I got it fixed. It was indeed problem with jcr:content only. It was available in our pages but was missing in the parent pages of the hierarchy. I just added the same and it started working. 🙂

Avatar

Administrator

Abhijit paul wrote...

Thanks Everyone for replying.

I got it fixed. It was indeed problem with jcr:content only. It was available in our pages but was missing in the parent pages of the hierarchy. I just added the same and it started working. 🙂

 

Thanks a lot for sharing the solution with the community.

~kautuk