Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

/etc/cloudsettings.kernel.js/libs/settings/cloudsettings/legacy/contexthub is giving 301 and not rendering the OOTB script for contexthub in author and publisher

Avatar

Level 3

Hi Experts,

In one of our environments the OOTB /etc/cloudsettings.kernel.js/libs/settings/cloudsettings/legacy/contexthub is giving 404. This issue happens both in author and publisher. The AEM version is 6.4.6.

But when I changed the sling:resourceType to "granite/contexthub/cloudsettings/components/baseconfiguration" it started working.

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Hello,

Yes, for "etc/cloudsettings/default/contexthub" the sling:resourceType should be "granite/contexthub/cloudsettings/components/baseconfiguration"

Note: As per the 6.4 repository restructuring there are some manual steps in regards to Context Hub -- https://helpx.adobe.com/experience-manager/6-4/sites/deploying/using/repository-restructuring-in-aem...

Regards,

Vishu

 

View solution in original post

2 Replies

Avatar

Correct answer by
Employee Advisor

Hello,

Yes, for "etc/cloudsettings/default/contexthub" the sling:resourceType should be "granite/contexthub/cloudsettings/components/baseconfiguration"

Note: As per the 6.4 repository restructuring there are some manual steps in regards to Context Hub -- https://helpx.adobe.com/experience-manager/6-4/sites/deploying/using/repository-restructuring-in-aem...

Regards,

Vishu

 

Avatar

Level 3

Hello @Vish_dhaliwal ,
We have done the restructuring, When we used OOTB config "/libs/settings/cloudsettings/legacy/contexthub" in Pages for loading contexthub specific scripts,
So on load of the page one of the call goes to /etc/cloudsettings.kernel.js/libs/settings/cloudsettings/legacy/contexthub, this call is failing in one of the environment.
Mean while the custom config which we have for project specific is rendering properly.