Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Error when Downloading assets in AEM 6.5.2

Avatar

Level 1

When trying to download any type of file from AEM, a ZIP file is generated but with no content at all.

This happens if I try to download 1 single file, or multiple files at the same time.

Do you know what could be the problem?

BRAGAD_0-1657212248739.png

 

Thanks in advance

1 Accepted Solution

Avatar

Correct answer by
Level 4

Hi @BRAGAD , You should be able to download any asset from AEM. If not, then please do these steps.

  1. Go to error.log & access.log files of that AEM instance & see what logs are printing there.
  2. Try to check your read permissions on that particular location. e.g: /content/dam/wknd/en/site

I tried to do it on wknd asset with just read permissions & its working good for me.

 

 

~Aditya.Ch

Screen Shot 2022-07-07 at 3.11.19 PM.png

 

View solution in original post

3 Replies

Avatar

Level 6

@BRAGAD 

 

Can you check on below points

1. Check logs for any errors

2. The download service creates a zip under /var/dam/donwloads. Check if the package is available at that location

3. Check if you have necessary permissions to download the assets

4. Are you doing this from author or publisher

Avatar

Correct answer by
Level 4

Hi @BRAGAD , You should be able to download any asset from AEM. If not, then please do these steps.

  1. Go to error.log & access.log files of that AEM instance & see what logs are printing there.
  2. Try to check your read permissions on that particular location. e.g: /content/dam/wknd/en/site

I tried to do it on wknd asset with just read permissions & its working good for me.

 

 

~Aditya.Ch

Screen Shot 2022-07-07 at 3.11.19 PM.png

 

Avatar

Community Advisor

Hi @BRAGAD ,

There can be few reasons, my suspects,

  • If you are downloading from CDN/Dispatcher then it should be a rule issue either in Dispatcher or CDN which is causing this.
  • Check if AssetDownloadService reference is not in satisfied state in AssetDownloadServlet . AssetDownloadService is dependent on other OOTB services and they should be in satisfied state. 
  • You can also check AEM error.log, request.log for this timeframe. As I said above, this download functionality leverages AEM Assets AssetDownloadServlet servlet. To ensure this servlet is available, the following request path must be open (ie. not blocked via AEM Dispatcher filters).
    HTTP POST /content/dam.assetdownload.zip/<ZIP File Name>.zip?licenseCheck=true&flatStructure=true&downloadSubassets=<true|false>&downloadRenditions=<true|false>

There is nothing to do with permissions, read permission is enough to download asset - If user doesn't have read permission - he/she can't even see the asset itself.

Hope that helps!

Regards,

Santosh