Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error - org.apache.sling.api.servlets cannot be resolved

harishred
Level 2
Level 2

Hello all, trying to build my project and getting below error in my OSGi after deploying it as a bundle... (Project created by archetype 23).. I am seeing below error:

org.apache.sling.api.servlets,version=[2.3,3) -- Cannot be resolved

I have this dependency added in my POM

 

<dependency>
    <groupId>org.apache.sling</groupId>
    <artifactId>org.apache.sling.api</artifactId>
    <version>2.3.0</version>
    <scope>provided</scope>
</dependency>

 

Tried all versions https://repo.adobe.com/nexus/content/groups/public/org/apache/sling/org.apache.sling.api/ but no luck. What am I missing?

 

Error from logs:

14.03.2020 22:36:12.200 *ERROR* [qtp1524159769-1650] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve akamdashapi.core [585](R 585.1): missing requirement [akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0))) Unresolved requirements: [[akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0)))])
org.osgi.framework.BundleException: Unable to resolve akamdashapi.core [585](R 585.1): missing requirement [akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0))) Unresolved requirements: [[akamdashapi.core [585](R 585.1)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.api.servlets)(version>=2.3.0)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)

@kautuk_sahni @Jörg_Hoh @Arun_Patidar 

 

AEM 6.5 applets osgi sling
1 Accepted Solution
chrisatsirius
Correct answer by
Level 2
Level 2

get service pack 4(6.5.4), it should fix your issue.

 

View solution in original post

11 Replies
harishred
Level 2
Level 2
When i used archetype 22, i dont see this issue.. looks like the issue is only with 23
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi,

 

Please look for the "Exported Packages" list of the bundle - Apache Sling API (org.apache.sling.api) in your instance.

We will have the servlets API mentioned with version as one among the list.

  • Make an entry of the same explicitly in the "Import-Package" list of bundle plugin in core/pom.xml

Also, the maven dependency to be added can be arrived at using system/console/depfinder.html which will be  - the whole of sling API bundle that exposes the servlets API.

sling-api-servlets.png

 

harishred
Level 2
Level 2
Hi @vijis, thank you. I've tried that already as you can see in my question.. infact its 2.2.1 like you have in your instance. and i added the maven dependency as well with no luck.
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi,

Ok. One final try, can you add the version number that comes in depfinder for your maven dependency. (I could see that you have tried all the versions mentioned in adobe repo)

If it is the same, then ignore. 

Arun_Patidar
Community Advisor
Community Advisor

Can you check what version of org.apache.sling.api.servlets you have in aem.

You can check using /system/console/depfinder

 

In AEM 6.5 It is 2.2.1

 

Please check https://stackoverflow.com/questions/20278236/org-apache-sling-api-resource-version-2-3-3-cannot-be-r...

 

harishred
Level 2
Level 2

Hi Arun, yes already checked that link you gave 🙂 .. the version i have is also 2.2.1

harishred_0-1584552602409.png

 

chrisatsirius
Correct answer by
Level 2
Level 2

get service pack 4(6.5.4), it should fix your issue.

 

View solution in original post

harishred
Level 2
Level 2
Yeah makes sense, i dont have access to the jar, but probably will request it later.. Prod is on 6.5.2 so doesnt make getting 6.5.4.. Hope archetype version had Aem versions it supports
vtjung
Level 1
Level 1
It works with service pack 6.5.4 (Archetype 23 und Cloud)