Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error in loading the Social Communities Components on HTTPS URL

monikaa6
Level 3
Level 3

Hi All,


We are upgrading from CQ5.6.1 to AEM 6.2 (Service Pack 2 and Communities Feature Pack2).

As part of the upgrade project we have extended some OOB components (Comments, ActivityStreams), these components renders fine in Dispatcher which is not a secure url (HTTP request), but they gave error on VIP (HTTPS URL)

In Dispatcher the below calls for social components

/services/social/getLoggedInUser?moderatorCheck=/content/testpage/jcr:content/firstColumn/custom_comment&h=/home/users/t/testuser1

getting redirected to the

".html" to appended to the URL

/services/social/getLoggedInUser.html?moderatorCheck=/content/testpage/jcr:content/firstColumn/custom_comment&h=/home/users/t/testuser1

After we allowed /services/social/getLoggedInUser.html in dispatcher it started working fine in dispatcher but throwing error in VIP

The URL was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint This request has been blocked; the content must be served over HTTPS.

The first request goes to

/services/social/getLoggedInUser.html?moderatorCheck=/content/testpage/jcr:content/firstColumn/custom_comment&h=/home/users/t/testuser1 over HTTPS which shows as cancelled request

Next request goes for same URL on HTTP which shows the above error.

Any idea, what could be the problem. If anyone face the similar issue and can help on this?

Thanks,

Monika

1 Accepted Solution
monikaa6
Correct answer by
Level 3
Level 3

Bertrand de Coatpont wrote...

Can you please check if your dispatcher is configured as per the documentation here: https://docs.adobe.com/docs/en/aem/6-2/deploy/communities/dispatcher.html

thank you

Bertrand

 

Thanks for the reply Bertrand.

There was some existing rewrite rule in dispatcher.conf file which was conflicting with this.

View solution in original post

3 Replies
monikaa6
Level 3
Level 3

Any insight on this?

Its becoming very crucial for our project to resolve this.

All communities components make a call to

/services/social/getLoggedInUser?moderatorCheck

which is returning the 301 redirect to /services/social/getLoggedInUser.html?moderatorCheck in Dispatcher

Any help is much appreciated

Thanks,

Monika

Bertrand_de_Coa
Employee
Employee

Can you please check if your dispatcher is configured as per the documentation here: https://docs.adobe.com/docs/en/aem/6-2/deploy/communities/dispatcher.html

thank you

Bertrand

monikaa6
Correct answer by
Level 3
Level 3

Bertrand de Coatpont wrote...

Can you please check if your dispatcher is configured as per the documentation here: https://docs.adobe.com/docs/en/aem/6-2/deploy/communities/dispatcher.html

thank you

Bertrand

 

Thanks for the reply Bertrand.

There was some existing rewrite rule in dispatcher.conf file which was conflicting with this.

View solution in original post