Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Encoding issue in invalid pages

Avatar

Avatar
Validate 1
Level 2
venkatreddyguda
Level 2

Likes

0 likes

Total Posts

20 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 2
venkatreddyguda
Level 2

Likes

0 likes

Total Posts

20 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
venkatreddyguda
Level 2

17-05-2019

Hi Folks,

I am using ACS Commons for error handling.We have multilingual site and when we try to open invalid page it is redirecting to 404 content but we are getting encoding issues for special charters and also for other languages.I see the response headers for the 404 get

Content-Type:

text/html;charset=ISO-8859-1

I added utf-8 encoding in jsp files and also checked osgi configuration to see default set to utf-8.Did i miss anything?

Thanks an in advance!

Replies

Avatar

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile

Avatar
Give Back 5
Level 4
Bharath_valse
Level 4

Likes

34 likes

Total Posts

65 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 25
Give Back 10
Give Back
View profile
Bharath_valse
Level 4

17-05-2019

Is the behavior same with 404s via publish instance? you might also want to check the default encoding on the Apache web-server as well

#

# Specify a default charset for all content served; this enables

# interpretation of all content as UTF-8 by default.  To use the

# default browser choice (ISO-8859-1), or to allow the META tags

# in HTML content to override this choice, comment out this

# directive:

#

AddDefaultCharset UTF-8

Avatar

Avatar
Validate 1
Level 2
venkatreddyguda
Level 2

Likes

0 likes

Total Posts

20 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 2
venkatreddyguda
Level 2

Likes

0 likes

Total Posts

20 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
venkatreddyguda
Level 2

20-05-2019

Hi Bharath,

Yes this is happening in Publish instance also.This is happening for only invalid pages all other pages are working fine.

Thanks,

Venkat