Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Dependency error while adding groovy through POM

Avatar

Level 4

Hi,

We are on AEM 6.5 version cloud. I added the following dependency on main pom, ui-apps pom and core pom files.

<dependency>
<groupId>de.valtech.aecu</groupId>
<artifactId>aecu.complete.cloud</artifactId>
<type>zip</type>
<version>6.2.0</version>
</dependency>

The below in the ui-apps pom:

<embedded>
<groupId>de.valtech.aecu</groupId>
<artifactId>aecu.complete.cloud</artifactId>
<type>zip</type>
<target>/apps/aemlab-vendor-packages/install</target>
</embedded>

kirthi_murali_1-1677739142821.png

 

Although, the maven build is success, the bundles related to groovy are not active. Following dependencies are showing error:

 

AEM Groovy Console - Bundle(aem-groovy-console-bundle)

com.day.cq.wcm.api,version=[1.29,2) -- Cannot be resolved
org.apache.jackrabbit.util,version=[2.5,3) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved


AEM Groovy Console - API(aem-groovy-console-api)

org.apache.commons.lang3.exception,version=[3.12,4) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved


AECU - Core(de.valtech.aecu.core)

com.day.cq.search,version=[1.4,2) -- Cannot be resolved
com.day.cq.wcm.api,version=[1.29,2) -- Cannot be resolved
org.apache.commons.lang3,version=[3.12,4) -- Cannot be resolved
org.apache.commons.lang3.builder,version=[3.12,4) -- Cannot be resolved
org.apache.commons.lang3.text,version=[3.12,4) -- Cannot be resolved
org.apache.commons.lang3.tuple,version=[3.12,4) -- Cannot be resolved
org.apache.jackrabbit.api,version=[2.6,3) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved
org.apache.sling.engine,version=[2.4,3) -- Cannot be resolved

 

AECU - API(de.valtech.aecu.api)

org.apache.commons.lang3,version=[3.12,4) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved


AECU - Cloud Startup Hook(de.valtech.aecu.cloud.startup.hook)

org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved

 

Is there anything missing in what I added or is there any other dependency that can be used instead?

 

Thanks in advance!

8 Replies

Avatar

Employee Advisor

Hi @kirthim ,

 

This seems to be an incompatibility between your SDK version and the plugin (groovy).

Try upgrading any of these so that appropriate dependencies can be resolved.

 

Hope that helps!

 

Regards,

Nitesh

 

Avatar

Level 4

@nitesh_kumar SDK version is 8 and the version for this pom I tried 6.2, 6.3 and LATEST as well. Same issue!

Avatar

Employee Advisor

Can you mention the full version name? 8 is quite abstract, something like (2022.9.8722.20220912T101352Z).

 

You can find recent versions of SDKs here, try with them

https://experience.adobe.com/#/downloads/content/software-distribution/en/aemcloud.html 

Avatar

Community Advisor

Hi,

Can you check the pom version here

https://github.com/arunpatidar02/aemaacs-aemlab/commit/3325b65bec062a549139156bc3584c743db67ff7 

 

<dependency>
	            <groupId>de.valtech.aecu</groupId>
	            <artifactId>aecu.complete.cloud</artifactId>
	            <type>zip</type>
	            <version>LATEST</version>
	        </dependency>


Arun Patidar

Avatar

Level 4

@arunpatidar I tried this, changed the version from 6.2 to 6.3 as well. Same issue! 

Can something else be causing this?

Avatar

Community Advisor

This is strange,

 

for me it resolved in local aem-sdk (version: Adobe Experience Manager (2022.9.8630.20220905T184657Z))

 

Screenshot 2023-03-02 at 17.00.58.png



Arun Patidar

Avatar

Level 4

Thank you for the inputs.
I just found out that for SP 8 this dependency is not working. I tried using SP 15 on my local and it works fine. 

Bu we have SP8 on our production so is there a way to get groovy installed for SP8?