Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

customized asset-share-commons for logout and need to optimize performance for aem6.5

Avatar

Level 7

Hi ,

We are using aem6.5 with customized asset-share-commons i.e. we have 

 

/apps/project-asset-share  for which we have overlayed from /apps/asset-share-commons

 

1> I would need to make changes to logout display

hence tried copying 

/apps/project-asset-share/components/structure/user-menu

from

 /apps/asset-share-commons/components/structure/user-menu

 

Tried to make changes to below file

/apps/project-asset-share/components/structure/user-menu/templates/profile.html

but it picks up changes only from the below file

 

/apps/asset-share-commons/components/structure/user-menu/templates/profile.html

 

2>The custom asset share page has custom filter and loads up very slowly what could I check across to increase the page load

 

Could someone provide inputs as how I could resolve this issues??

 

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 7

I was able to find this .

I had a entry under

/conf/project-asset-share/settings/wcm/templates/search-template/structure/jcr:content/root/rail/user_menu

 

Once I changed that it worked

 

Thanks for the help.

 

I need to still check on performance

View solution in original post

5 Replies

Avatar

Community Advisor

Hi @srinivas_chann1 ,

 

Did you restart before testing if the overlay works ? I know it's lame, but its recommended to restart for overlays to work.

Thanks.

Avatar

Community Advisor

Did you update the correct resource-type in the page so that it refers to 

/apps/project-asset-share/components/structure/user-menu
instead of

 /apps/asset-share-commons/components/structure/user-menu

Avatar

Correct answer by
Level 7

I was able to find this .

I had a entry under

/conf/project-asset-share/settings/wcm/templates/search-template/structure/jcr:content/root/rail/user_menu

 

Once I changed that it worked

 

Thanks for the help.

 

I need to still check on performance

Avatar

Employee Advisor

Regarding item 2 (performance): Do you know what is slow? On which environment is it slow? How many assets do you have in that environment where you find it slow?