Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Custom namespace not displaying in metadata schema editor form

jitendra_m
Level 2
Level 2

Hi,

I have created a custom namespace in crx/explorer, but when mapping it to any field in metadata schema editor form, it is not displaying.

Please let me know if I am missing anything.

AEM version: 6.4

Thanks,

Jitendra

4 Replies
smacdonald2008
Level 10
Level 10

Please describe the procedure you are doing to perform this use case. I am also checking with the team on this use case.

jitendra_m
Level 2
Level 2

Hi Veena,

I have created custom namespace by opening http://localhost:4502/crx/explorer/index.jsp > Node Type Administration > Namspaces > created new namespace named "demo".

But when I am editing the metadata schema form and mapping this property to custom field, the namespace is not visible in the list.

Also, when I manually provide property in "Map to property" field, the custom field is working fine and it is actually showing the field when opening any asset's properties.

1710626_pastedImage_0.png

So, the only issue is namespace is not visible in mapping list in metadata schema form.

Veena_Vikram
Community Advisor
Community Advisor

I am not sure about the expected behavior.  Since it is saving , it should be fine I believe. I will do some RnD on existing behavior though