Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Custom multifield in page properties not working

Avatar

Level 4

I have a custom multi field in page properties which is saving values as child node. In AEM 6.1, it is working fine. But after migrating to AEM 6.3, I am able to add the values in dialog for the first time, and on save, it is getting saved as expected in page node. But next time when I open the dialog, the values are not getting populated. The dialog is working fine if it is added as component dialog.This is happening when it  a part of page properties. I could see so many similar posts in the forum, but couldn't find a solution. Did any one face similar issue and were able to resolve it?

6 Replies

Avatar

Level 10

Looks like a bug. If it works in a component dialog - then is valid. I recommend opening a support ticket so this can be fixed.

Avatar

Level 2

How did u resolve the issue? I am facing the same issue with AEM 6.3 upgrade, with lower version it saved data in properly

Avatar

Community Advisor

Hi,

If you are using Granite Multifield component then use composite(Boolean)=true in field property.

Multifield — Granite UI 1.0 documentation



Arun Patidar

Avatar

Level 2

This worked with "coral" multifield not with "granite/ui/components/foundation/form/multifield"

Avatar

Community Advisor

Hi for Coral2, there is no composite property because content save as JSON.

Please check your multifield node structure if it is not correct then values will be saved as common separated for individual property and doesn't repopulate.



Arun Patidar