Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

CQ5.6.1 Replication Queue gets stuck, no errors are seen - a manual refresh of adobe.cq.replication bundle is required to get it going

Avatar

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
anjali_biddanda
Level 3

15-10-2015

Hi All,

We're newly launched to production and we're noticing a problem that we've not seen before. Our replication agents (author-to-author, author-to-publisher) get stuck without reason holding items in the queue and we see no errors in the replication logs or in the error logs in both publishers (if the queue gets stuck during replication from publisher-to-publisher for example). As soon as we do Refresh of the 'Adobe Granite Replication' bundle (adobe.cq.replication), we immediately see the queue dissipate. We do have patch cq-5.6.1-hotfix-4101-1.0.zip installed (OutOfMemoryError on publish during replication of much data). Selecting the top most item in the queue and doing a Force Retry does nothing. We see no information in the replication agent logs or error log. 

Why is it that a bundle refresh gets the queue moving again?

Any help will be much appreciated.

Thanks.

View Entire Topic

Avatar

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
anjali_biddanda
Level 3

15-10-2015

Yes thanks - our replication agents are enabled and configured correctly as mentioned in that link. However mid-way through replications, the queue gets stuck. So say 5000 items in queue, for no reason when it's down to say 2100, the queue gets stuck and we see nothing in the logs; no errors, and no information when we force retry an entry in the queue. At this point doing a fresh of the bundle, gets the queue moving again. Nothing else does it.