Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

CQ 5.6 Felix Console Not Accessible

Avatar

Former Community Member

Hi,

I am unable to access my author instance -felix console and am getting the following error while trying to access it. Please help me in resolving this.

No resource found

Cannot serve request to /system/console in /libs/sling/servlet/errorhandler/404.jsp

Request Progress:

0 (2015-04-08 15:26:57) TIMER_START{Request Processing} 0 (2015-04-08 15:26:57) COMMENT timer_end format is {<elapsed msec>,<timer name>} <optional message> 0 (2015-04-08 15:26:57) LOG Method=GET, PathInfo=/system/console 0 (2015-04-08 15:26:57) TIMER_START{ResourceResolution} 0 (2015-04-08 15:26:57) TIMER_END{0,ResourceResolution} URI=/system/console resolves to Resource=NonExistingResource, path=/system/console 0 (2015-04-08 15:26:57) LOG Resource Path Info: SlingRequestPathInfo: path='/system/console', selectorString='null', extension='null', suffix='null' 0 (2015-04-08 15:26:57) TIMER_START{ServletResolution} 0 (2015-04-08 15:26:57) TIMER_START{resolveServlet(NonExistingResource, path=/system/console)} 1 (2015-04-08 15:26:57) LOG {0}: no servlet found 1 (2015-04-08 15:26:57) TIMER_END{1,resolveServlet(NonExistingResource, path=/system/console)} Using servlet org.apache.sling.servlets.get.DefaultGetServlet 1 (2015-04-08 15:26:57) TIMER_END{1,ServletResolution} URI=/system/console handled by Servlet=org.apache.sling.servlets.get.DefaultGetServlet 1 (2015-04-08 15:26:57) LOG Applying Requestfilters 1 (2015-04-08 15:26:57) LOG Calling filter: org.apache.sling.bgservlets.impl.BackgroundServletStarterFilter 1 (2015-04-08 15:26:57) LOG Calling filter: org.apache.sling.i18n.impl.I18NFilter 1 (2015-04-08 15:26:57) LOG Calling filter: org.apache.sling.rewriter.impl.RewriterFilter 1 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.designimporter.CanvasPageDeleteRequestFilter 1 (2015-04-08 15:26:57) LOG Calling filter: com.adobe.cq.history.impl.HistoryRequestFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.core.impl.WCMRequestFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.mycompany.myproject.impl.filters.LoggingFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.mycompany.testproject.impl.filters.LoggingFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.adobe.granite.optout.impl.OptOutFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.theme.impl.ThemeResolverFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.foundation.forms.impl.FormsHandlingServlet 2 (2015-04-08 15:26:57) LOG Calling filter: org.apache.sling.engine.impl.debug.RequestProgressTrackerLogFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.mobile.core.impl.redirect.RedirectFilter 2 (2015-04-08 15:26:57) LOG RedirectFilter did not redirect (request extension does not match) 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.core.impl.warp.TimeWarpFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.core.impl.AuthoringUIModeServiceImpl 2 (2015-04-08 15:26:57) LOG Applying Componentfilters 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.personalization.impl.TargetComponentFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.core.impl.WCMComponentFilter 2 (2015-04-08 15:26:57) LOG Calling filter: com.day.cq.wcm.core.impl.WCMDebugFilter 2 (2015-04-08 15:26:57) TIMER_START{org.apache.sling.servlets.get.DefaultGetServlet#0} 2 (2015-04-08 15:26:57) TIMER_END{0,org.apache.sling.servlets.get.DefaultGetServlet#0} 3 (2015-04-08 15:26:57) LOG Applying Error filters 3 (2015-04-08 15:26:57) LOG Calling filter: org.apache.sling.rewriter.impl.RewriterFilter 3 (2015-04-08 15:26:57) TIMER_START{handleError:status=404} 3 (2015-04-08 15:26:57) TIMER_END{0,handleError:status=404} Using handler /libs/sling/servlet/errorhandler/404.jsp 3 (2015-04-08 15:26:57) LOG Found processor for post processing ProcessorConfiguration: {contentTypes=[text/html],order=-1, active=true, valid=true, processErrorResponse=true, pipeline=(generator=Config(type=htmlparser, config={}), transformers=(Config(type=linkchecker, config={}), Config(type=mobile, config=JcrPropertyMap [node=node /libs/cq/config/rewriter/default/transformer-mobile, values={component-optional=true, jcr:primaryType=nt:unstructured}]), Config(type=mobiledebug, config=JcrPropertyMap [node=node /libs/cq/config/rewriter/default/transformer-mobiledebug, values={component-optional=true, jcr:primaryType=nt:unstructured}]), Config(type=contentsync, config=JcrPropertyMap [node=node /libs/cq/config/rewriter/default/transformer-contentsync, values={component-optional=true, jcr:primaryType=nt:unstructured}]), serializer=Config(type=htmlwriter, config={}))} 4 (2015-04-08 15:26:57) TIMER_END{4,Request Processing} Dumping SlingRequestProgressTracker Entries
1 Accepted Solution

Avatar

Correct answer by
Employee

webconsole plugin has not started for some reason.Are you able to access /libs/cq/core/content/login.html

1) cd /crx-quickstart/launchpad/felix

2) grep -H "org.apache.felix.webconsole" . -R

3) look for org.apache.felix.webconsole-<some number>.jar

4) Go to that bundle "cd <bundle number>"

5) Check bundle.location file it should contain slinginstall:org.apache.felix.webconsole-<some number>.jar

6) open bundle.state file and change state to "active" from "installed"

7) Restart your system

View solution in original post

5 Replies

Avatar

Level 10

Are you getting this error after logging with admin/admin ? Usually, this error would come when there is no access for a particular request

Avatar

Correct answer by
Employee

webconsole plugin has not started for some reason.Are you able to access /libs/cq/core/content/login.html

1) cd /crx-quickstart/launchpad/felix

2) grep -H "org.apache.felix.webconsole" . -R

3) look for org.apache.felix.webconsole-<some number>.jar

4) Go to that bundle "cd <bundle number>"

5) Check bundle.location file it should contain slinginstall:org.apache.felix.webconsole-<some number>.jar

6) open bundle.state file and change state to "active" from "installed"

7) Restart your system

Avatar

Former Community Member

Yes , I am getting this eror for admin/admin credentials..

Avatar

Former Community Member

I did manual start up .i.e executed the run.sh file from crx-quickstart/bin and now its working. Could please tell what went wrong in previous case. I have not come across this issue before

Avatar

Level 10

Seems there was an attempt to restart the webconsole bundle either due to your code deployment etcc....  The bundle was not running & caused to access felix console