Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

CQ 5.6.1 templates & components on AEM 6.4

Julio_Baixauli
Level 4
Level 4

Hi Masters!

I’m working with templates and components developed originally in CQ 5.6.1, but now deployed on an AEM 6.4 instance.

Basically, my templates are static templates with some typical <cq:include path="par" resourceType="foundation/components/parsys"/>. I know the components need the new TouchUI dialogs (cq:dialog), but we can start with the EXT version for now.

At first sight, site pages work fine in TouchUI. They render well. Also, I’ve checked the Blueprint/Livecopy functionalities and works fine. But the problem is that we can’t see the ‘edit’ button when we click on any component. We can only see ‘Copy’, ‘Group’ and ‘Convert…’. The component is already on the page, so it’s not a ‘design mode’ issue.

Any idea?

Kind regards.

4 Replies
bilal_ahmad
Level 5
Level 5

Thanks ton, Jörg​​, Here is the complete URL request :

  1. Request URL: http://localhost:4502/mnt/overlay/wcm/core/content/editor/_jcr_content/content/items/content/content...
  2. Request Method: GET
  3. Status Code: 403 Forbidden
  4. Remote Address: [::1]:4502
  5. Referrer Policy: no-referrer-when-downgrade

Also, adding the components in parsys works just fine. I get the error every time I click on any parsys.

Jörg_Hoh
Employee
Employee

Looking at the URL I cannot deduce what function is involved. Anyhow the status code 403 indicates a permission problem. Does the logs indicate any problems?

Jörg_Hoh
Employee
Employee

Can you check the statuscode of a request to

/mnt/overlay/wcm/core/content/editor/_jcr_content/content/items/conte nt/content/items/styleselector.form.html

and

/content/MySite/sites/en-us/bilal-test-page/_jcr_c ontent/standardpage-mainpar/

bilal_ahmad
Level 5
Level 5

Hi Jörg​, got these status codes-

/mnt/overlay/wcm/core/content/editor/_jcr_content/content/items/conte nt/content/items/styleselector.form.html - 200

/content/MySite/sites/en-us/bilal-test-page/_jcr_c ontent/standardpage-mainpar/ - 403

Many Thanks.

aemmarc
Employee
Employee

That 403 is because the asterisk is appended to the URL and Sling has no idea how to resolve it.  It's a TouchUI thing when the user clicks on Add Component, it's been a known thing for a while.

That 403 is a dead end.

bilal_ahmad
Level 5
Level 5

Thank you so much, It is indeed not causing any issue. I am able to add/edit/delete the components, just that it bothers me every time I click on the parsys, and see 403-forbidden in the console. Much appreciated your valuable input.

bilal_ahmad
Level 5
Level 5

unfortunately, no. We have left it as it is until it creates any issue for us. It just shows error in the network tab and we have accepted to live with that

cyderek
Level 1
Level 1

I'm having the same 403 issue, migrating from aem 6.2 to 6.5. May I know if there is a ticket is opened for this 'known' issue? Thanks in advance.