Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Content fragment downloaded content doesn't display text properly in IE

Avatar

Avatar
Validate 1
Level 2
ranjna
Level 2

Likes

7 likes

Total Posts

32 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 2
ranjna
Level 2

Likes

7 likes

Total Posts

32 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
ranjna
Level 2

04-09-2018

Hi

I got an issue while downloaded the content of content fragment which was in spanish.

After download the file is saved as zip and while extracted there is a main.html inside it which contains the content fragment content.

while opening that main.html with internet explorer and mozila firefox , the spanish accent content converts into special characters and content is not readable.

The content is appearing properly in chrome.

In crx/de while i kept meta tag <meta UTF-8>  in front of content fragment in original file , content appears properly in all the browsers but this solution is not applicable where i have content fragment in bulk and all the fragment is getting updated many times.

So looks like the issue is with encoding . Somewhere while downloading the encoding is not happening for the content properly.

Could anyone help me knowing, Is this the known issue in AEM? Is there any other solution to mitigate it?

Any leads would be really appreciated

Thanks,

Ranjna

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,406 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

05-09-2018

I have never heard of this - could be a bug. I recommend opening a support ticket.