Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

[Console][Error][AEM 6.4.8] We see a 403 Forbidden when clicking on =Drag a component=

Avatar

Employee

We see a 403 Forbidden when clicking on "Drag a component". It can be simulated in AEM OOTB

Version: 6.4.8

Env: probably any but using macOS mojave 10.14.6

Browser: Chrome Version 84.0.4147.89 (Official Build) (64-bit)

Run Mode - Author running in 4012 port
Sample page : 

http://localhost:4512/editor.html/content/we-retail/us/en/about-us.html

Click on the "Drag a component" that is present above the footer

Check the console log and network log

there will be a redirection and we get

http://localhost:4512/mnt/overlay/wcm/core/content/editor/_jcr_content/content/items/content/content/items/styleselector.form.html/content/we-retail/us/en/about-us/_jcr_content/root/responsivegrid/*/ 403 (Forbidden)

 

Kindly advice. 

 

1 Accepted Solution

Avatar

Correct answer by
Employee

Sling will have no idea how to resolve */

 

But what you're seeing is a non-issue, the asterisk is used as some selector in the front end and try adding a trailing / to any path it will also 403.

 

How are you impacted by this specifically? 

View solution in original post

8 Replies

Avatar

Employee

Hi @RaghuA,

Can you confirm if you have permission (read, write, modify, delete) enabled for this path /content/we-retail/us/en/about-us/?

Thanks!!

Avatar

Employee
I have admin access. Its a localhost vanila AEM 6.4 update to 6.4.8 service pack.. May be this issue is there in 6.4 also not sure.

Avatar

Correct answer by
Employee

Sling will have no idea how to resolve */

 

But what you're seeing is a non-issue, the asterisk is used as some selector in the front end and try adding a trailing / to any path it will also 403.

 

How are you impacted by this specifically? 

Avatar

Employee
Thanks. Did not find impacts seeing this in console error logs.

Avatar

Employee
Found more information around this and looks like there is fix in 6.5.4

Avatar

Community Advisor

@RaghuA , 

Verified on 6.4 instance. Looks fine for me. 

Please do double check if the user has create/modify permission. 

Avatar

Employee
Thanks. Looks like there is a fix in ui.styleSelector.js as part of 6.5.4