Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Configure tool in AEM option not coming while creating live copy using MSM tool under CRXDE

Preeti5
Level 2
Level 2
 
1 Accepted Solution
Preeti5
Correct answer by
Level 2
Level 2

Hi @Asutosh_Jena_ 

Thankyou so much, actually there was some issue with hero root image now it's working.Thankyou

View solution in original post

3 Replies
Asutosh_Jena_
Community Advisor
Community Advisor

Hi @Preeti5 

 

Could you please add some more information or any screenshot to understand the issue a bit more?

 

Thanks!

Preeti5
Correct answer by
Level 2
Level 2

Hi @Asutosh_Jena_ 

Thankyou so much, actually there was some issue with hero root image now it's working.Thankyou

View solution in original post

kautuk_sahni
Community Manager
Community Manager

@Preeti5 Thank yo for shaing the solution with community. This could help in posterity. Looking forward to more contributions from you. 

Asutosh_Jena_
Community Advisor
Community Advisor

Hi @Preeti5 

 

There is no difference between these 2 URLs.

1. This is the absolute URL so the resource resolution will happen from /libs

2. This is the relative URL, so the resource resolution will happen from /apps and if no resource available then it will go to /libs.

 

Link to refer:

https://aemmastery.com/aem-osgi-service-dive-resource-resolver-factory-c2521f75be51

 

Thanks!

Preeti5
Level 2
Level 2
  • Hi @Asutosh_Jena_ Thanks..so by default it will search under /libs if nothing mentioned 
Asutosh_Jena_
Community Advisor
Community Advisor

If nothing mentioned it will search under /apps followed by /libs.

 

It's always recommended to keep it relative i.e., without /apps or /libs so that if required we can add our own implementation under /apps and it will be picked at runtime without any code change.

 

Thanks!