Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Compilation errors in org/apache/sling/scripting/sightly/apps/core/wcm/components/commons/editor/dialog/inherited/v1/inherited/render_html.java: Line 39, column 2543 : com.adobe.cq.wcm.core.components.commons.editor.dialog.inherited.InheritedField canno...

Avatar

Level 2

Hello Team,

I've requested and received a trial version of AEM and successfully registered with the supplied license key. 

 

Now I try to run the WKND tutorial. I have downloaded the latest version from Github and have run the command:

mvn clean install -PautoInstallSinglePackage -Pclassic
 
I am unable to create a page in the WKND site. The following error occurs:

Compilation errors in org/apache/sling/scripting/sightly/apps/core/wcm/components/commons/editor/dialog/inherited/v1/inherited/render_html.java: Line 39, column 2543 : com.adobe.cq.wcm.core.components.commons.editor.dialog.inherited.InheritedField cannot be resolved to a type

Cannot serve request to /mnt/overlay/wcm/core/content/sites/createpagewizard/properties.html/conf/wknd/settings/wcm/templates/article-page-template in /libs/granite/ui/components/foundation/form/field/field.jsp

Exception:

org.apache.sling.scripting.sightly.SightlyException: Compilation errors in org/apache/sling/scripting/sightly/apps/core/wcm/components/commons/editor/dialog/inherited/v1/inherited/render_html.java:
Line 39, column 2543 : com.adobe.cq.wcm.core.components.commons.editor.dialog.inherited.InheritedField cannot be resolved to a type
	at org.apache.sling.scripting.sightly.impl.engine.compiled.SlingHTLMasterCompiler.compileSource(SlingHTLMasterCompiler.java:429)
	at org.apache.sling.scripting.sightly.impl.engine.compiled.SlingHTLMasterCompiler.compileHTLScript(SlingHTLMasterCompiler.java:245)
	at org.apache.sling.scripting.sightly.impl.engine.SightlyScriptEngine.compile(SightlyScriptEngine.java:58)
	at org.apache.sling.scripting.core.impl.DefaultSlingScript.call(DefaultSlingScript.java:379)
	at org.apache.sling.scripting.core.impl.DefaultSlingScript.eval(DefaultSlingScript.java:184)
	at org.apache.sling.scripting.core.impl.DefaultSlingScript.service(DefaultSlingScript.java:491)

 

When checking on localhost:4502/system/console/bundles the Adobe Experience Manager Core WCM Components Core Bundle is not active but just installed. It shows several packages could not be found, a few examples:

com.fasterxml.jackson.annotation,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.core,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind.annotation,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind.introspect,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind.module,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind.ser,version=[2.11,3) -- Cannot be resolved
com.fasterxml.jackson.databind.ser.std,version=[2.11,3) -- Cannot be resolved

 

I already tried several combinations of uber.jar and core.wcm.componets versions according to this page:

https://experienceleague.adobe.com/en/docs/experience-manager-core-components/using/versions

 

Sadly it didn't work out.

 

Any help would be greatly appreciated.

 

Regards,

Jens.

 

 

1 Accepted Solution

Avatar

Correct answer by
Level 2

Ok, you gave me a hint here. I have downloaded Service Pack 6.5.20.0, installed it and everything works.

 

Thank you!

 

View solution in original post

3 Replies

Avatar

Level 2

Hello @Bhuwan_B ,

from the quickstart.properties file:

#Created by com.adobe.granite.quickstart.base.impl.upgrade.UpgradeUtil at Mon Apr 15 16:29:34 CEST 2024
#Mon Apr 15 16:29:34 CEST 2024
quickstart.build=0.0.0.0_0_0_6_5_.20190328
 
 

Avatar

Correct answer by
Level 2

Ok, you gave me a hint here. I have downloaded Service Pack 6.5.20.0, installed it and everything works.

 

Thank you!