Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

com.day.cq.cq-rewriter FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null.) org.osgi.framework.ServiceException: Service factory returned null. - AEM 6.1 SP2 CFP13

Dharanya
Level 2
Level 2

Hi,

@

Our instance is running on AEM 6.1 SP2 CFP13. We have upgraded from AEM 6.1 GA to AEM 6.1 SP2 CFP13. Post upgrade, we were performing all the maintenance activity.Things were good. All of a sudden version purge activity which was configured as Daily Maintenance Window disappeared. While trying to reconfigure version purge as part of daily maintenance window again below errors were logged in error.logs

" *ERROR* [10.20.67.123 [1519021772363] GET /libs/granite/operations/content/maintenance/window.html/mnt/overlay/granite/operations/config/maintenance/_granite_daily HTTP/1.1] org.apache.jackrabbit.oak.plugins.segment.SegmentTracker Segment not found: f56d94ff-2cdd-41dd-ad52-2f34bdff9df3. Creation date delta is 83950376 ms.

org.apache.jackrabbit.oak.plugins.segment.SegmentNotFoundException: Segment f56d94ff-2cdd-41dd-ad52-2f34bdff9df3 not found "

We tried restarting the instance to over come this issue and ran into a different problem. Upon restart all our bundles were in active state.

But we are unable to access consoles like

      1) projects.html, siteadmin, damadmin etc., As it resulted in below message

1422693_pastedImage_0.png

Where in, few consoles like crx/de , crx/packmgr, system/console, crx/explorer are accessible.

We could see below error in error logs:

*ERROR* [pool-5-thread-6] com.day.cq.cq-rewriter [com.day.cq.rewriter.linkchecker.impl.LinkCheckerTransformerFactory(1111)] Failed creating the component instance; see log for reason

*ERROR* [FelixDispatchQueue] com.day.cq.cq-rewriter FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null.)

org.osgi.framework.ServiceException: Service factory returned null.

at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:376)

at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:243)

at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:357)

at org.apache.felix.framework.Felix.getService(Felix.java:3671)

at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:470)

at org.apache.felix.eventadmin.impl.handler.EventHandlerProxy.obtain(EventHandlerProxy.java:286)

at org.apache.felix.eventadmin.impl.handler.EventHandlerProxy.sendEvent(EventHandlerProxy.java:407)

at org.apache.felix.eventadmin.impl.tasks.SyncDeliverTasks.execute(SyncDeliverTasks.java:118)

at org.apache.felix.eventadmin.impl.handler.EventAdminImpl.sendEvent(EventAdminImpl.java:147)

at org.apache.felix.eventadmin.impl.security.EventAdminSecurityDecorator.sendEvent(EventAdminSecurityDecorator.java:96)

at org.apache.sling.jcr.resource.internal.OakResourceListener.sendOsgiEvent(OakResourceListener.java:284)

at org.apache.sling.jcr.resource.internal.OakResourceListener.changed(OakResourceListener.java:170)

at org.apache.jackrabbit.oak.plugins.observation.NodeObserver$NodeEventHandler.leave(NodeObserver.java:217)

at org.apache.jackrabbit.oak.plugins.observation.FilteredHandler.leave(FilteredHandler.java:51)

at org.apache.jackrabbit.oak.plugins.observation.EventGenerator$Continuation.run(EventGenerator.java:175)

at org.apache.jackrabbit.oak.plugins.observation.EventGenerator.generate(EventGenerator.java:117)

at org.apache.jackrabbit.oak.plugins.observation.NodeObserver.contentChanged(NodeObserver.java:162)

at org.apache.jackrabbit.oak.spi.commit.BackgroundObserver$1$1.call(BackgroundObserver.java:131)

at org.apache.jackrabbit.oak.spi.commit.BackgroundObserver$1$1.call(BackgroundObserver.java:125)

at java.util.concurrent.FutureTask.run(FutureTask.java:262)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

at java.lang.Thread.run(Thread.java:744)

Could someone help us in resolving this issue.Thanks in advance.

3 Replies
kautuk_sahni
Employee
Employee

Due to some reason your repository got corrupted. Kindly run oak utility to fix segment store issue. You need to download oak jar file according to your AEM instance and then you need to run few commands.

also have a look at Fix Inconsistencies in the repository when SegmentNotFound Issue is reported in AEM 6.x

-Kautuk

Dharanya
Level 2
Level 2

Thanks kautuksahni​ for your quick response. We will try out the same.

w0lver_n3
Level 2
Level 2

Hi Dharanya,

Did you try the fix suggested by Kautuksahni? Did it work? I am also facing the same issue. Please do let me know.

Thanks,

Kasyap.