Highlighted

com.adobe.cq.social.scf.core.AbstractSocialComponentFactory.getClientUtilities in aem communities

swati_kad

26-10-2018

Hi,

I am getting the error in aem 6.4 in com.adobe.cq.social packages as com.adobe.cq.social.ugcbase.core.SocialResourceUtils is deprecated in 6.4. I have added 

the below dependency in my pom.

<dependency>

                <groupId>com.adobe.cq.social</groupId>

                <artifactId>cq-social-commons</artifactId>

                <version>1.5.103</version>

            </dependency>

          <dependency>

                <groupId>com.adobe.cq.social</groupId>

                <artifactId>cq-socialcommunities-api</artifactId>

                <version>1.10.111</version>

                <scope>provided</scope>

           </dependency>

When I add any community component on my page then in publish mode it gives me error. 1607201_pastedImage_8.png

and in logs I am getting :

1607202_pastedImage_9.png

1607203_pastedImage_10.png

Please suggest what should i do to resolve this error in 6.4