Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

Bundles in installed mode

Avatar

Level 8

Hi,

I have a project xxxx project the bundle is installed mode.

These are the errors inside the bundle 
javax.activation,version=[1.2,2) -- Cannot be resolved
com.day.cq.dam.commons.process,version=[3.2,4) -- Cannot be resolved
com.adobe.aem.wcm.seo.sitemap,version=[1.1,2) -- Cannot be resolved
com.adobe.cq.wcm.core.components.models,version=[12.25,13) -- Cannot be resolved

 

I am having these versions
Aem instance is 6.5.11

com.adobe.cq.core.wcm.components.core version 2.20.8

com.adobe.aem.wcm.seo.sitemap version 1.0.6

com.day.cq.dam.commons.process,version 3.1.0

 

Can anyone help.

 

 

 

 

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hello @Vani1012 

 

1. Rather than installing 2.19.0 on top of 2.20.8, can you please try on a fresh AEM install (6.5.11).

That might give you the expected results.

As suggested by others, 2.20.8 is compatible for 6.5.13.0+ *

For 6.5.11, please use 2.19.0

 

2. Make sure that you are using 6.5.11 uber-jar

3. The dependencies related to "core.wcm.components" in projects pom should use 2.19.0 version


Aanchal Sikka

View solution in original post

7 Replies

Avatar

Level 8

I have changed core components version to 2.19.0 even after that same errors getting.

Avatar

Level 4

Please check if the uber jar version also same.

https://mvnrepository.com/artifact/com.adobe.aem/uber-jar/6.5.11

Try restarting the server once it might help

Thanks

 

Avatar

Community Advisor

Hi @Vani1012 ,

 

You should check the dependencies versions what you have added in the project POM and what you are getting from the uber jar included.

 

Thanks,

Ritesh

Avatar

Community Advisor

Hi @Vani1012,

 

Core component version 2.20.8 is not compatible with AEM 6.5.11, Please refer this link below

https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=...

Screen Shot 2023-01-06 at 10.54.13 AM.png

Hope that helps!

Regards,

Santosh

Avatar

Correct answer by
Community Advisor

Hello @Vani1012 

 

1. Rather than installing 2.19.0 on top of 2.20.8, can you please try on a fresh AEM install (6.5.11).

That might give you the expected results.

As suggested by others, 2.20.8 is compatible for 6.5.13.0+ *

For 6.5.11, please use 2.19.0

 

2. Make sure that you are using 6.5.11 uber-jar

3. The dependencies related to "core.wcm.components" in projects pom should use 2.19.0 version


Aanchal Sikka