Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Build Error while converting project to cloud runnable image for AEMaaCS.

Avatar

Level 2

Hi Team,

 

My current project is in AEM 6.5 and trying to deploy it on AEMaaCS. Our team resolved all the code related issues and code quality scan is passed as well. In the 3rd build step, while converting the project to cloud runnable image, I got below error:

  • [ERROR] [api-regions-exportsimports] <my-project-core>:1.0-SNAPSHOT: Bundle <my-project-core>:1.0-SNAPSHOT is importing package(s) [com.adobe.fd.signatures.pki.client.types.prefs, com.adobe.fd.signatures.pki.client.types.common, com.adobe.fd.docassurance.client.api, com.adobe.fd.signatures.pdf.inputs, com.adobe.fd.encryption.client, com.adobe.acs.commons.email, com.adobe.fd.signatures.client.types] in start level 20 but no bundle is exporting these for that start level.
  • [ERROR] [api-regions-exportsimports] <my-project-core>:1.0-SNAPSHOT: Bundle <my-project-core>:1.0-SNAPSHOT is importing package(s) Package com.adobe.aemfd.docmanager;version=[1.9,2) in start level 20 but no visible bundle is exporting these for that start level in the required version range.

 

I got little idea about this error from here.

 

 I referred this doc to include ACS commons classes and resolved that part.

The rest of the classes are coming from AEM Forms addon package.

 

Issue occurred when I tried the similar approach of embedding aemfd-client-sdk jar in the pom.

I added below part in pom

 

 

    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.jackrabbit</groupId>
                <artifactId>filevault-package-maven-plugin</artifactId>
                <extensions>true</extensions>
                <configuration>
	            <embedded>
		        <groupId>com.adobe.aemfd</groupId>
		        <artifactId>aemfd-client-sdk</artifactId>
		        <filter>true</filter>
	            </embedded>
...

 

 

I was hoping that "aemfd-client-sdk" jar might have all the packages provided by Forms package. Also, I shouldn't have done this as after this aemfd-client-sdk showed up in the /system/console/bundles with unresolved dependencies.

Build was successful after embedding aemfd jar but now in the image build, analyser asked to do the same for aemfd-client-sdk:

  • [ERROR] [api-regions-exportsimports] com.adobe.aemfd:aemfd:-client-sdk: Bundle aemfd:-client-sdk is importing package(s) [com.adobe.idp.um.api.infomodel, com.rits.cloning, com.adobe.aemds.bedrock, com.adobe.livecycle.content.model.annotation, com.adobe.aemfd.docmanager.internal.passivation.jcr, org.dom4j.io, com.adobe.fd.signatures.pki.impl, org.omg.CORBA, com.adobe.icc.data, com.adobe.ps.cm.config, com.adobe.fd.signatures.hsm, com.adobe.fd.signatures.hsm.api, com.adobe.fd.signatures.impl, net.sf.beanlib.provider.finder, com.adobe.livecycle.content.appcontext, com.adobe.fd.signatures.pki.revocation.crl, com.adobe.exm.expeval.functionutil, com.adobe.internal.pdfm.util, org.dom4j, com.adobe.aemfd.docmanager.internal.persistence, com.adobe.service, com.adobe.fd.signatures.hsm.internal.transaction.util, com.adobe.aemfd.docmanager.internal.passivation, com.adobe.aemfd.docmanager.internal.passivation.url, com.adobe.livecycle.content.activate.exception, com.adobe.fd.signatures.pki.cert, org.dom4j.dom, org.apache.commons.el, net.sf.beanlib.spi, com.adobe.fd.signatures.truststore.businessobject, net.sf.beanlib.provider.replicator, com.adobe.aemds.formset.utils, com.adobe.fd.signatures.pki.client.types, net.sf.beanlib.provider, com.adobe.aemds.guide.progressive, com.adobe.livecycle.content.repository, com.adobe.aemfd.docmanager.internal.source, com.adobe.fd.fp.util, com.adobe.fd.signatures.pki.client] in start level 20 but no bundle is exporting these for that start level.
  • [ERROR] [api-regions-exportsimports] com.adobe.aemfd:aemfd:-client-sdk: Bundle aemfd:-client-sdk is importing package(s) [Package com.adobe.forms.option;version=[3.7,4), Package com.adobe.xfa;version=[3.6,4), Package com.adobe.xfa.ut;version=[3.6,4), Package com.adobe.aemds.guide.themes.model;version=[3.10,4), Package com.adobe.aemds.guide.transformer.api;version=[3.10,4), Package com.adobe.xfa.content;version=[3.6,4), Package com.adobe.aemds.guide.submitutils;version=[3.10,4), Package com.adobe.forms.foundation.util;version=[2.0,3), Package com.adobe.aem.dermis.util;version=[1.0,2), Package com.adobe.xfa.protocol;version=[3.6,4), Package com.adobe.aemfd.docmanager.source;version=[1.9,2), Package com.adobe.aemfd.dermis.authentication.util;version=[1.1,2), Package com.adobe.xfa.configuration;version=[3.6,4), Package com.adobe.xfa.template.containers;version=[3.6,4), Package com.adobe.xfa.data;version=[3.6,4), Package com.adobe.xfa.localeset;version=[3.6,4), Package com.adobe.internal.pdftoolkit.services.javascript;version=null, Package com.adobe.aemfd.docmanager.io;version=[1.9,2), Package com.adobe.internal.pdftoolkit.pdf.document;version=null, Package com.adobe.xfa.template;version=[3.6,4), Package com.adobe.forms.foundation.transfer;version=[2.0,3), Package org.apache.commons.beanutils;version=[1.8,2), Package com.adobe.forms.foundation.service;version=[1.6,2), Package com.adobe.forms.foundation.oauth.model;version=[1.0,2), Package com.adobe.aemds.guide.service.internal;version=[3.11,4), Package com.adobe.forms.common.utils;version=[5.9,6), Package com.adobe.xfa.connectionset;version=[3.6,4), Package com.adobe.xfa.template.ui;version=[3.6,4), Package com.adobe.forms.service;version=[3.7,4), Package com.adobe.xfa.template.formatting;version=[3.6,4), Package com.adobe.forms.foundation.service.util;version=[1.6,2)] in start level 20 but no visible bundle is exporting these for that start level in the required version range.

 

I just want to know how can I resolve these similar dependencies on AEM Forms Addon package.

 

 

Adding more to the Question, the packages throwing errors in the analyser logs are not resolved in AEM cloud local setup as well:

SanidhyaGaur_1-1639666313602.png

So, to use these packages in my code in AEMaaCS, what are the packages I should use?

In my local AEM cloud sdk I have already installed forms addon latest tool from Software Distribution that should have resolved this but didn't.

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Have you followed the instructions how to bootstrap a forms project at 

mvn -B archetype:generate -DarchetypeGroupId=com.adobe.aem -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=32 -DaemVersion="cloud" -DappTitle="My Site" -DappId="mysite" -DgroupId="com.mysite" -DincludeFormsenrollment="y"

 

Other than a regular Sites/Assets project you need additional dependencies for forms:

        <!-- AEM Forms Dependencies -->
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>aem-forms-sdk-api</artifactId>
            <version>${aem.forms.sdk.api}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-apps</artifactId>
            <type>zip</type>
            <version>${core.forms.components.version}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-core</artifactId>
            <version>${core.forms.components.version}</version>
        </dependency>


(I copied this from the boostrapped project created by the mvn example on the linked docs page)

View solution in original post

1 Reply

Avatar

Correct answer by
Employee Advisor

Have you followed the instructions how to bootstrap a forms project at 

mvn -B archetype:generate -DarchetypeGroupId=com.adobe.aem -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=32 -DaemVersion="cloud" -DappTitle="My Site" -DappId="mysite" -DgroupId="com.mysite" -DincludeFormsenrollment="y"

 

Other than a regular Sites/Assets project you need additional dependencies for forms:

        <!-- AEM Forms Dependencies -->
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>aem-forms-sdk-api</artifactId>
            <version>${aem.forms.sdk.api}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-apps</artifactId>
            <type>zip</type>
            <version>${core.forms.components.version}</version>
        </dependency>
        <dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>core-forms-components-core</artifactId>
            <version>${core.forms.components.version}</version>
        </dependency>


(I copied this from the boostrapped project created by the mvn example on the linked docs page)

Avatar

Level 2

Hi Jörg,

 

Thanks for the reply, I tried adding above dependencies just now and also tried embedding the packages in my project similar to the way it was in the bootstrapped project, but the build failed with exactly same errors.

Also, forgot to mention, I am using sandbox env.

Maybe the dependencies are correct but the version I am trying to import is wrong?

Is there a way to check which which packages are required for below dependencies that I can embed and also what version for these packages would be required for an AEM 6.5.5 project?

I just know that these are coming from Forms addon package.

"com.adobe.fd.signatures.pki.client.types.prefs, com.adobe.fd.signatures.pki.client.types.common, com.adobe.fd.docassurance.client.api, com.adobe.fd.signatures.pdf.inputs, com.adobe.fd.encryption.client, com.adobe.fd.signatures.client.types, 

com.adobe.aemfd.docmanager;version=[1.9,2)"

 

Thanks,

Avatar

Level 2

Adding more to the Question, the packages throwing errors in the analyser logs are not resolved in AEM cloud local setup as well:

SanidhyaGaur_1-1639666313602.png

So, to use these packages in my code in AEMaaCS, what are the packages I should use?

In my local AEM cloud sdk I have already installed forms addon latest tool from Software Distribution that should have resolved this but didn't.

 

Avatar

Level 2

Hi @Sanidhya-Gaur  did you resolve this problem?

 

I have same problem now. On local instance my project compiles but on Cloud I have same errors than you but I do not use forms addons on my project, so I do not have to import libraries suggested above. 

Thanks!

 

Avatar

Level 2

Actually the issue was we were trying to make changes in the existing pom which was created using old archetype.

 

To fix it, we decided to change the whole pom and built the maven project again using recommended maven archetype for AEMaaCS.

The analyser should already be included in the new project archetype.

 

Before the build, we added the dependencies in the embed that were appearing in the analyser build errors just like the way mentioned in this article.

 

And the Forms Add On related bundle resolved after installing the forms add on provided in Software Distribution page and added below entries in the "all" project's pom.xml:

 

...
                        <embedded>
                            <groupId>com.adobe.aem</groupId>
                            <artifactId>core-forms-components-apps</artifactId>
                            <type>zip</type>
                            <target>/apps/<your-project-path>/install</target>
                        </embedded>
                        <embedded>
                            <groupId>com.adobe.aem</groupId>
                            <artifactId>core-forms-components-core</artifactId>
                            <target>/apps/<your-project-path>/install</target>
                        </embedded>

 

Thanks,