Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AuthenticationSupport error occured when upgrading from CQ 5.4 to AEM 6.1

Avatar

Level 2

Hi,

I have tried to upgrade CQ 5.4 to AEM 6.1 by following Adobe's document https://docs.adobe.com/docs/en/aem/6-1/deploy/upgrade.html), upgradation was successful. But, when I open the instance, it says "Startup in process". When I check the logs, "AuthenticationSupport service missing. Cannot authenticate request." 

Kindly, help me on this.

Thank you.

1 Accepted Solution

Avatar

Correct answer by
Employee

Your repository has not started properly, which is why you get this message. Check your error log, there should be an exception earlier in the startup process. Also check https://docs.adobe.com/docs/en/aem/6-1/release-notes/known-issues.html#Known%20Issues to make sure you are not encountering similar issues.

Regards

View solution in original post

0 Replies

Avatar

Level 2

Hi,

I have tried all ways to upgrade from CQ 5.4 to AEM 6.1, but have failed due to the issues in repository migration. So, I have done an intermediate migration to AEM 6.0 from CQ 5.4. Even then, I'm facing a few problems for which I'm seeking help.

Things I've done:

  • I have created a sample page with basic content in 5.4 version.
  • I also have deleted the Geometrixx package in 5.4 as stated in the documentation ( http://docs.adobe.com/docs/en/aem/60/deploy/upgrade.html )
  • Replaced the jars and have run the command (java -jar aem-quickstart.jar -r crx2) -> works fine till here, because it is still using the old CRX2 repo. I could see the sample page I've created.
  • I have placed the migration tool in the installation folder and have follwed the step under the heading "MIGRATING THE REPOSITORY TO OAK" after which I'm facing issues. I have attached a part of the error.log file where the error shows. 
  • I have also used the sanity check tool. [img]Sanity Check wrt 6(CRX3).png[/img] [img]Sanity Check wrt 6(SP1).png[/img] 

Please help.

Avatar

Correct answer by
Employee

Your repository has not started properly, which is why you get this message. Check your error log, there should be an exception earlier in the startup process. Also check https://docs.adobe.com/docs/en/aem/6-1/release-notes/known-issues.html#Known%20Issues to make sure you are not encountering similar issues.

Regards

Avatar

Level 2

Hi

I have exactly the ***same*** behaviour and I have been struggling with it for the past weeks.

I start from a 5.4 instance, migration from crx2 to crx3 oak is working fine. When last step is executed (upgrade to AEM 6.1) I start to see a lot of errors related to missing dependencies on bundles.

To try to limit possible "application errors" I deleted all my application code (deleted everything under /apps) and I deleted ALL application bundles (I have only contents).

The result is exactly the same... after last migration step I can see web console, I can see crxde and verify all my contents have been migrated. But any other page is returning "starting..." with an error related to authentication support missing.

I'm doing the migration on Linux redHat (and yes, I already found and corrected the problem related to back slashes in configuration).

I managed to have a working migration (with very few contents) locally on a windows instance. The only difference I see from my local instance and the production isntance is that the local is an OOTB installation without any hotfixes / feature packs. Now I'm going to verify if the application of hotfixes / feature packs on a CQ 5.4 is going to trigger such problem on the migration.

Anyway... the migration process from 5.4 to AEM 6.1 seems very tricky and very time consuming....

Hope a solution can be found since with a half Tera repository doing and redoing migration attemps is going to take a ***LOT*** of time.

Avatar

Level 2

Thank you Opkar Gill.

My instance was not opening after I have migrated my versions. I have searched for fixes like deleting the index files, but it didn't work in that case.

I have followed the link you've mentioned. I could not install hotfix as it is saying "There are no clouds available to install this package."  And, when I download the zip file, I do not know where to put that in my <crx-quickstart> folder.
Also, steps in the link you've specified can only be done when I can access CRXDE, which I'm not able to do. Can you please help me fix from here.

Avatar

Level 2

Thank you, Sham HC.
I've already tried using Sanity check, but I'm unable to find the expected versions it is asking for anywhere on the internet.

Avatar

Employee

Hi,

1. You first need to find out what exceptions are been thrown during startup, the error you posted above is the effect of the exceptions, not the root cause.

2. There is no hotfix needed, which hotfix have you downloaded, I only see a hotfix for Target, are you using Target?

3. You only need to use CRXDE if you have issues with content targeting, which I am assuming you are not.

4. The known issues section has two key points to check

  • Update to 6.1 from 5.x and 6.0+CRX2 using crx2oak fails if installation path contains a space. Move quickstart folder into path with no space. (CQ-39859)
  • Update to 6.1 from 5.x and 6.0+CRX2 fails on Windows due to backslashes written to FileDataStore.cfg. Workaround is to modify the 'org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.cfg' file with datastore path before we run Migration command (CQ-42291)

Does your installation path have spaces?

Are you using Windows?

 

Regards

Avatar

Level 10

kameshwaris62670443 wrote...

Thank you, Sham HC.
I've already tried using Sanity check, but I'm unable to find the expected versions it is asking for anywhere on the internet.

 


The output indicates upgrade is not complete & some thing missed up.  Please file daycare ticket and attach all the logs at the time of upgrade.

Avatar

Level 2

Opkar Gill wrote...

Hi,

1. You first need to find out what exceptions are been thrown during startup, the error you posted above is the effect of the exceptions, not the root cause.

2. There is no hotfix needed, which hotfix have you downloaded, I only see a hotfix for Target, are you using Target?

3. You only need to use CRXDE if you have issues with content targeting, which I am assuming you are not.

4. The known issues section has two key points to check

  • Update to 6.1 from 5.x and 6.0+CRX2 using crx2oak fails if installation path contains a space. Move quickstart folder into path with no space. (CQ-39859)
  • Update to 6.1 from 5.x and 6.0+CRX2 fails on Windows due to backslashes written to FileDataStore.cfg. Workaround is to modify the 'org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.cfg' file with datastore path before we run Migration command (CQ-42291)

Does your installation path have spaces?

Are you using Windows?

 

Regards

 

 

Hi,

I have checked with these two points. My installation path has no spaces and I'm using Windows OS. I have overwritten the config file with '/'. yet no progress.

Thank you.

Avatar

Employee

You would need to update the configuration file before running the migration command. So it can't be done after you have done your migration, can you rerun the migration?

Also, what exceptions are you getting in your log file? (Not "AuthenticationSupport service missing. Cannot authenticate request.")

Avatar

Employee

Opkar Gill wrote...

You would need to update the configuration file before running the migration command. So it can't be done after you have done your migration, can you rerun the migration?

Also, what exceptions are you getting in your log file? (Not "AuthenticationSupport service missing. Cannot authenticate request.")

 

To be clear here: do you have a copy of your original instance to rerun the upgrade process?

Just before the migration command is run, you need to change the configuration file as per the instructions for windows systems.

Avatar

Level 2

Hi Opkar,

I am using an original instance, despite which I'm facing the problem. Apart from AuthenticationSupport service missing error, I got a BundleException.

Thanks in advance.

Avatar

Employee

kameshwaris62670443 wrote...

Hi Opkar,

I am using an original instance, despite which I'm facing the problem. Apart from AuthenticationSupport service missing error, I got a BundleException.

Thanks in advance.

 

 

Hi,

what I meant is you need to start again with your 5.4 instance(I'm guessing you made a copy before the upgrade).

Perform the upgrade as per the docs, BUT, Just before the migration command is run, you need to change the configuration file as per the instructions for windows systems in the Known Issues page.

Regards.