Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Authentication support service missing

Avatar

Level 3

Getting Authentication support service missing while starting aem instance, tried to find good revision but that is showing no good revision found, is there any way to get the instance working without restoring any backups?

10 Replies

Avatar

Level 3

Hi Dinesh,

Check if /system/console/bundles are opening for you ? if yes, then check for oak bundles if it is in resolved state.

Thanks,
Amogh

Avatar

Level 3

yes, I can access system console, i see all bundles are active there too.

Avatar

Administrator

Please share with us AEM error.log.

Meanwhile pleas have a look at this reference post:- http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

//Thread talks about AEM 6.1 Startup Error: Missing Authentication Service 

~kautuk



Kautuk Sahni

Avatar

Level 9

Hi Dinesh,

  It needs some back end operation to identify or create good revision on your instance.  Please engage with official support team 

Thanks,

Avatar

Community Advisor

dinesh sundaram wrote...

Getting Authentication support service missing while starting aem instance, tried to find good revision but that is showing no good revision found, is there any way to get the instance working without restoring any backups?

 

If all your bundles are active and still you are getting the same error, then try deleting and re-indexing the content. When indexes gets corrupt, then you run into this error. Sometimes you will need to club that up with Tar compaction too.

If your bundles are not coming to an active state and are staying in installed phase, then try to stop the Bundle - Apache Sling Resource-Based Discovery Service (org.apache.sling.discovery.impl) from felix console and restart your server. Once all the other bundles turn active, then you can start the discovery bundle again.

~Runal

Avatar

Level 3

I have tried re-indexing and tried to find good revision too but no luck.

Avatar

Level 3

Hi Dinesh,

Try this:

  1. Check your oak version by searching "oak" in "\crx-quickstart\launchpad\felix" folder.
  2. Download same version bundle from maven.
  3. Create install folder under crx-quickstart and place downloaded jar over there.
  4. Start your instance.
  5. Check bundles status, refresh if it is in resolved state.

*Make sure your instance is stopped before doing above steps.

Thanks,
Amogh

Avatar

Level 3

I just followed this steps, all bundles are active but I still see Authentication support service is missing while accessing /crx/explorer/login.jsp

Avatar

Level 3

dinesh sundaram wrote...

I just followed this steps, all bundles are active but I still see Authentication support service is missing while accessing /crx/explorer/login.jsp

 


Can you try restarting once ? And if doesn't work after that, try tar compaction.