Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

Angular components are not loading with AEM 6.5.14, getting Unexpected token 'const'

Avatar

Level 2

Hi everyone, 

Since Monday the 11th, I have been experiencing issues with loading all my Angular components. They were working fine on my local and development instances until Friday, but after one build, all my Angular components stopped loading. We have observed that we are encountering a specific error that we do not encounter in instances where the previous code is working fine.

 

clientlib-<org>-data.min.<hash>.js:3 Uncaught SyntaxError: Unexpected token 'const' (at clientlib-<org>-data.min.<hash>.js:3:307220)

 

I have attempted to revert to previous versions, but the issue persists even after clearing the cache.

I could use some assistance in getting unblocked. Any help would be greatly appreciated.

 

2 Replies

Avatar

Community Advisor

Hi, 

 

It looks like the JS (clientlibs) are not properly constructed/minified.

 

I would suggest narrowing down the issue to determine if it was caused by the ServicePack, which I assume you applied (based on the title of this thread). You can do this by installing your code into a fresh AEM instance. Alternatively, if the issue arose due to changes in your code, deploying a stable version, perhaps the one you have in production, can help identify if someone introduced the issue in the code. If that's the case, you should validate the issue using your SCM (Source Code Management) tool.



Esteban Bustamante

Avatar

Level 2

Hi @EstebanBustamante, About a year ago, we installed service pack 6.5.14 and it has been working well up until Friday. However, suddenly it started to malfunction. I have attempted to install previous versions of my code, but even the versions that were previously functioning properly are now not working at all.