Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Anchor tag and id issue

tc82
Level 4
Level 4

Am seeing some issues with anchor tag in AEM rich text editor.

IN RTE if i use the the following:

<a href="test.com"> testing</a> -- Works well, href exists all the time.

second case:

<a href="test.com" id="test"> testing</a>

in source edit once you try to edit again, it becomes

<a  id="test"> testing</a> -- Doesn't work well, href is removed .

I have tried changing the  following file:

/apps/cq/xssprotection/config.xml

but nothing helped.

Has anyone seen this issue.

1 Accepted Solution
kautuk_sahni
Correct answer by
Community Manager
Community Manager

You can use the link icon for hyperlinking.

Here the concept of the anchor tag is placeholder hyperlink. To jump to a location within a page.

Here is the helpx article with package to do testing:- Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

~kautuk

View solution in original post

4 Replies
tc82
Level 4
Level 4

Sorry forgot to mention. We are using AEM 6.3

kautuk_sahni
Correct answer by
Community Manager
Community Manager

You can use the link icon for hyperlinking.

Here the concept of the anchor tag is placeholder hyperlink. To jump to a location within a page.

Here is the helpx article with package to do testing:- Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

~kautuk

View solution in original post

tc82
Level 4
Level 4

kautuksahni​ We can try using that, but when users dump the whole html in the source edit, this issues is hard to resolve.