Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

After dropping the component getting console error.

Avatar

Level 6

I have added component to the page but it is not appearing until I refresh the page. Even listner for referesh page is not working I need to refresh manually then only component is appearing  Component( RTE, Drop Down, text field  only these field are there)

 

Ronnie09_0-1652704876555.png

This is the console error I am getting while dropping the component to the page

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @Ronnie09 

I faced similar issue in classic ui where I noticed that in ootb file libs/cq/ui/widgets/source/widgets/wcm/EditBase.Listeners.js there was a logic related to checking selector with was failing essentially adding  a"..html" at the end of the post call.

 

Similarly for your core.js where it is failing can you try to troubleshoot/debug and find what file the issue is happening and why? It could be another issue and not same, but just wanted to share if that helps and a similar approach can help. Please share the part where it is failing in core.js. 

View solution in original post

1 Reply

Avatar

Correct answer by
Community Advisor

Hi @Ronnie09 

I faced similar issue in classic ui where I noticed that in ootb file libs/cq/ui/widgets/source/widgets/wcm/EditBase.Listeners.js there was a logic related to checking selector with was failing essentially adding  a"..html" at the end of the post call.

 

Similarly for your core.js where it is failing can you try to troubleshoot/debug and find what file the issue is happening and why? It could be another issue and not same, but just wanted to share if that helps and a similar approach can help. Please share the part where it is failing in core.js.