Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

AEM Useradmin and Miscadmin pages are blank , Also search inside CRX/DE home and CRX Package Manager search is not working

Avatar

Level 2

AEM Useradmin and Miscadmin pages are blank , and Also search inside CRX/DE home and CRX Package Manager search is not working

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Please check all the bundles are active, after that please check the logs to see if any issues may be causing this. Also, try to restart the instance and see if that solves the issue. Do you have any idea how this started? a deployment failure or something else?


 



Esteban Bustamante

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

Please check all the bundles are active, after that please check the logs to see if any issues may be causing this. Also, try to restart the instance and see if that solves the issue. Do you have any idea how this started? a deployment failure or something else?


 



Esteban Bustamante

Avatar

Level 7

Hi @maryani 

where are you trying? Local or in other (Dev/QA) environment? Do you have proper access?

Can you try to access the URL again and try?

Avatar

Level 3

Hi @maryani Useradmin and Miscadmin pages are blank: This could be due to a number of reasons such as permission issues, misconfiguration, or technical glitches. Here's a bash snippet to check if there are any sub-nodes below /system/sling/installer/jcr/pauseInstallation, which might be causing the issue:

COUNT_NODES=$(curl -s -S -f -m 60 -u admin:admin_password "http://localhost:4502/system/sling/installer/jcr/pauseInstallation.1.json" | jq -r 'keys|.[]' | grep -cvE '(jcr:created|jcr:createdBy|jcr:primaryType|jcr:mixinTypes)')
if [[ ${COUNT_NODES} -gt 0 ]]; then
echo "Found $COUNT_NODES sub-nodes below /system/sling/installer/jcr/pauseInstallation, please remove them and deploy again"
exit 1
else
echo "No pauseInstallation nodes found"
fi

 

CRX/DE home and CRX Package Manager search is not working:This could be due to an unfinished Service Pack update. You can use the following bash snippet to wait for the AEM Service Pack Updater to finish:

timeout=1800
starttime=$(date +%s)
echo "Waiting until AEM Service Pack Updater is finished ..."
until (($(date +%s) > starttime+timeout)) || ! curl -s -S -f -u admin:admin_password "http://localhost:4502/system/console/bundles.json" | jq -r -e '.data[] | select(.symbolicName|test("^updater."))'; do
sleep 5
done
if (($(date +%s) > starttime+timeout)); then
log "AEM Service Pack Updater did not finish after ${timeout}s."
exit 1
fi
echo "AEM Service Pack Updater is finished."

  1. After ensuring the Service Pack Updater is finished, you can try the search again.

Please replace admin:admin_password with your actual admin credentials. Also, these are general troubleshooting steps .If the problem persists, you might need to dig deeper into the logs and configuration settings.

 

Avatar

Administrator

@maryani Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni