Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM tutorial webdav rights issue

dawid_van_der_m
Level 1
Level 1

Hi.

Busy working through the this AEM 6.1 tutorial (https://docs.adobe.com/docs/en/aem/6-1/develop/the-basics/website.html).

Got the webdav windows 7 client working and I can access *some* folders however, not the /etc/designs/mywebsite required by by the tutorial.

The moment I try to expand the /etc folder I get an access denied error.

Kinda stuck now, heeeeeelp!

Tx.

1 Accepted Solution
Opkar_Gill
Correct answer by
Employee
Employee

Yes, it does seem so: https://docs.adobe.com/docs/en/aem/6-1/administer/content/webdav-access.html 

Windows 7

For Windows 7: Basic authentication for WebDav is disabled by default. To enable it, the following entry in the registry has to be updated to 2 or greater in the web client:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel

Possible values: 2 or greater - Basic authentication for SSL shares and non-SSL shares.

You need to reboot after changing the registry. See http://support.microsoft.com/kb/841215/en-us for more information.

In addition, you need to have a Windows user with the same credentials as the repository user, otherwise you will get permission problems.

View solution in original post

3 Replies
dawid_van_der_m
Level 1
Level 1

Seems to be related to Windows 7. I accessed the webdav server from Linux and it was working 100%.

Opkar_Gill
Employee
Employee

Hi,

what user are you trying to log in as? Does the user have access to the folder? Check the permissions using CRXDE Lite.

Regards,

Opkar

Opkar_Gill
Correct answer by
Employee
Employee

Yes, it does seem so: https://docs.adobe.com/docs/en/aem/6-1/administer/content/webdav-access.html 

Windows 7

For Windows 7: Basic authentication for WebDav is disabled by default. To enable it, the following entry in the registry has to be updated to 2 or greater in the web client:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel

Possible values: 2 or greater - Basic authentication for SSL shares and non-SSL shares.

You need to reboot after changing the registry. See http://support.microsoft.com/kb/841215/en-us for more information.

In addition, you need to have a Windows user with the same credentials as the repository user, otherwise you will get permission problems.

View solution in original post