AEM Screens Player fails to generate token

Avatar

Avatar

Karl515

Avatar

Karl515

Karl515

24-06-2019

Hello,

We installed the most compatible AEM Screens Player version to the server's version (that is 6.4.2), Then configured the player to connect to the server. But the player fails to generate token, with the status under System Information "initial (link-up) (unauthenticated)".

Moreover, we have followed server configuration in https://helpx.adobe.com/experience-manager/6-4/screens/using/configuring-screens-introduction.html. rough summary:

   * Allow Empty Referrer Requests

   * Enable Touch UI for AEM Screens

   * AEM in NOSAMPLECONTENT runmode

   * Password Restriction

1778370_pastedImage_0.png

1778371_pastedImage_1.png

We've also tried /system/console/configMgr/org.apache.jackrabbit.oak.spi.security.user.action.DefaultAuthorizableActionProvider yet still to no good.

What could be the issue?

Thanks

Replies

Avatar

Avatar

tanyakapila

Employee

Avatar

tanyakapila

Employee

tanyakapila
Employee

25-06-2019

System wide user password restrictions might cause failure in the device registration. The device registration uses a random generated password to create the device user.

If the password is restricted by the AuthorizableActionProvider configuration, creating the device user might fail. I request you to try removing any password restriction at

system/console/configMgr/org.apache.jackrabbit.oak.spi.security.user.action.DefaultAuthorizableActio...

Avatar

Avatar

Karl515

Avatar

Karl515

Karl515

25-06-2019

Hi.

Yup it was removed. That's why I've stated it in my question. But still no good.

Thanks.

what else could have cause the error?

Avatar

Avatar

sukritikohli

Avatar

sukritikohli

sukritikohli

14-07-2019

Did you get any solution for this?
I am facing the same issue