Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Aem Reports Title does not accept underscore(_)

Shetty119
Level 2
Level 2

Hi Team,

In AEM Reports title if I give _ it throughs JS console errors.

e.g. Report_title

Errors:

TypeError: null is not an object (evaluating 'collectionEl.dataset')

TypeError: null is not an object (evaluating 'document.getElementById("asset-reports-rail-properties").innerHTML = response')

 

Please suggest.

 

Thanks,

Soujanya.

1 Accepted Solution
snbaem
Correct answer by
Community Advisor
Community Advisor

Looks like js side errors, Can you please check error logs too? 
If nothing is seen, can you please add debug logs to com.day.cq.dam.api.reporting? In case some details are found there.

Also what version and url are you on to see this or any steps to recreate this?

 

View solution in original post

4 Replies
Dipti_Chauhan
Community Advisor
Community Advisor

Hi @Shetty119 

  Are you getting this error while creating Asset report?

 

Thanks

Dipti

snbaem
Correct answer by
Community Advisor
Community Advisor

Looks like js side errors, Can you please check error logs too? 
If nothing is seen, can you please add debug logs to com.day.cq.dam.api.reporting? In case some details are found there.

Also what version and url are you on to see this or any steps to recreate this?

 

View solution in original post

Shetty119
Level 2
Level 2
Thank you Snbean. This issue is related to my code. Resolved it.