Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

AEM Mihgration 6.3 to 6.5 SAML Issue

Avatar

Community Advisor

Hello guys,

 

I am facing an issue during migration from AEM 6.3 to AEM 6.5 on SAML . It seems that com.adobe.granite.auth.saml.util.* library is not supported in AEM 6.5 . Any suggestion?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Employee

Yes you can remove them

View solution in original post

4 Replies

Avatar

Community Advisor

Hello @Luca_Lattarini 

 

The SAML via "Adobe Granite SAML 2.0 Authentication Handler" 
should work with AEM 6.5 as well.

 

However, there are no exported packages for the corresponding bundle

aanchalsikka_0-1690864228246.png

 


Aanchal Sikka

Avatar

Employee

@Luca_Lattarini This issue is coming because in AEM 6.3 the saml bundle used to have exported packages

varun249715_2-1690874762639.png

where as in AEM 6.5 the exported packages are not there.

I think for now you can import the missing/deprecated packages to make it work.

 

Avatar

Community Advisor

Hello @varun249715 

it seems that this library are in the maven build exceotion.Shall i remove from  exception?

Avatar

Correct answer by
Employee

Yes you can remove them