Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM local user preference not updated (backend)

zaddm
Level 1
Level 1

I have backend implementation that adds property under preference node. Example /home/users/S/aiowerlakjf_lkjwer/preference

I am using service user to update user preference. All the users' preference are updating as expected, however there is one user which is replicated, preference of this user is not updating. The only difference between this user and rest of the users is, it is replicated. 

I am not sure why would this even be an issue. 

I would appreciate if you can share your experience related to updating users in AEM and if you have encountered similar issues.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
bangar50
Correct answer by
Level 7
Level 7

Hi @zaddm ,

                     I was faced same issue and I did deactivate that user and again activate then the issue was resolved for me. Can you please try the same thing.

 

Kr,

Sanjay

View solution in original post

3 Replies
bangar50
Correct answer by
Level 7
Level 7

Hi @zaddm ,

                     I was faced same issue and I did deactivate that user and again activate then the issue was resolved for me. Can you please try the same thing.

 

Kr,

Sanjay

View solution in original post

ArpitVarshney
Community Advisor
Community Advisor

Hi @zaddm 

Can you put your logs in debug mode and check what error is coming in logs when your code try to add the property for replicated users?

 

Regards,

Arpit Varshney