Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM fail to start

Sam205505050
Level 6
Level 6

I'm trying to start AEM on Windows 7 machine by double clicking on jar cq-author-4502. When I'm trying to open through browser http://host:port then getting below message -

Resource dumped by HtmlRendererServlet

Resource path: /libs/cq/core/content/projects

Resource metadata: {sling.resolutionPathInfo=.html, sling.resolutionPath=/libs/cq/core/content/projects}

Resource type: cq:Page

Resource super type: -

Resource properties

jcr:createdBy: admin
jcr:created: java.util.GregorianCalendar[time=1378587067491,areFieldsSet=true,areAllFieldsSet=true,lenient=false,zone=sun.util.calendar.ZoneInfo[id="GMT-04:00",offset=-14400000,dstSavings=0,useDaylight=false,transitions=0,lastRule=null],firstDayOfWeek=1,minimalDaysInFirstWeek=1,ERA=1,YEAR=2013,MONTH=8,WEEK_OF_YEAR=36,WEEK_OF_MONTH=1,DAY_OF_MONTH=7,DAY_OF_YEAR=250,DAY_OF_WEEK=7,DAY_OF_WEEK_IN_MONTH=1,AM_PM=1,HOUR=4,HOUR_OF_DAY=16,MINUTE=51,SECOND=7,MILLISECOND=491,ZONE_OFFSET=-14400000,DST_OFFSET=0]
jcr:primaryType: cq:Page

Error in stderr.log -

08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/commerce/install/cq-commerce-core-5.6.16.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.commerce.cq-commerce-core [148]: Unable to resolve 148.0: missing requirement [148.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)])
org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.commerce.cq-commerce-core [148]: Unable to resolve 148.0: missing requirement [148.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)]
08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.026 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/commerce/install/cq-commerce-pim-5.6.6.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.commerce.cq-commerce-pim [149]: Unable to resolve 149.0: missing requirement [149.0] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.commerce.api)(version>=1.1.0)) [caused by: Unable to resolve 148.0: missing requirement [148.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)]])
org.osgi.framework.BundleException: Unresolved constraint in bundle com.adobe.cq.commerce.cq-commerce-pim [149]: Unable to resolve 149.0: missing requirement [149.0] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.commerce.api)(version>=1.1.0)) [caused by: Unable to resolve 148.0: missing requirement [148.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)]]
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.032 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/cq/analytics/install/cq-analytics-5.6.12.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-analytics [153]: Unable to resolve 153.0: missing requirement [153.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)])
org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-analytics [153]: Unable to resolve 153.0: missing requirement [153.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.personalization) [caused by: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)]
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.074 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/cq/compat/install/cq-compat-migration-medialib-1.0.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-compat-migration-medialib [177]: Unable to resolve 177.0: missing requirement [177.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.dam.core))
org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-compat-migration-medialib [177]: Unable to resolve 177.0: missing requirement [177.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.dam.core)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.642 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/cq/personalization/install/cq-opensocial-5.6.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-opensocial [185]: Unable to resolve 185.0: missing requirement [185.0] osgi.wiring.package; (osgi.wiring.package=org.apache.sanselan))
org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-opensocial [185]: Unable to resolve 185.0: missing requirement [185.0] osgi.wiring.package; (osgi.wiring.package=org.apache.sanselan)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.956 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel] ERROR: Error starting jcrinstall:/libs/cq/personalization/install/cq-personalization-5.6.6.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-personalization [186]: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api))
org.osgi.framework.BundleException: Unresolved constraint in bundle com.day.cq.cq-personalization [186]: Unable to resolve 186.0: missing requirement [186.0] osgi.wiring.package; (osgi.wiring.package=com.day.cq.wcm.api)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3896)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.startBundle(Felix.java:1938)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1261)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel]     at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:298)
08.09.2013 14:50:13.958 *ERROR* [FelixStartLevel]     at java.lang.Thread.run(Unknown Source)
 

 

I can see all the jar files are available through crxde lite. Kindly let me know pointers .

1 Accepted Solution
Sham_HC
Correct answer by
Level 10
Level 10

Seems all the bundles are not started. can you tr restarting with [1].

[1]   java -Xmx2024m -XX:MaxPermSize=512M -jar cq5-author-4502.jar &

View solution in original post

3 Replies
Sham_HC
Correct answer by
Level 10
Level 10

Seems all the bundles are not started. can you tr restarting with [1].

[1]   java -Xmx2024m -XX:MaxPermSize=512M -jar cq5-author-4502.jar &

Sam205505050
Level 6
Level 6

Thanks for your reply. I was able to open it after I tried 2 times. But I do not find default Geomatrix example under apps. Do you know any reason for this?

So I tried with CQ 5.4 which was running fine before I tried with CQ 5.6. Now I'm facing another issue with CQ 5.4. I'm able to open welcome screen but when I'm trying to open Website/DAM/Inbox/Users from welcome screen then page control is going back to Welcome screen. 

access.log

192.168.1.101 - admin 13/Sep/2013:00:03:34 -0400 "GET /libs/cq/core/content/welcome/ico_users.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:34 -0400 "GET /libs/cq/core/content/welcome/featurebox_bground.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:34 -0400 "GET /libs/cq/core/content/welcome/featurebox_top.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/fading_line.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/search_icon.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/search_middle.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/search_right.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/search_left.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:36 -0400 "GET /libs/cq/core/content/welcome/box_glow.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:27 -0400 "GET /libs/cq/core/content/welcome.html HTTP/1.1" 200 8662 "http://localhost:4502/libs/cq/core/content/login.html?resource=%2F%3Fwfc_path%3D%2F%26wfc_expected_v..." "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:37 -0400 "GET /libs/cq/core/content/welcome/bg_about.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:37 -0400 "GET /libs/cq/core/content/welcome/featurebox_bottom.png HTTP/1.1" 304 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:38 -0400 "GET /siteadmin HTTP/1.1" 302 - "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:38 -0400 "GET /libs/wcm/core/content/siteadmin.html HTTP/1.1" 200 2766 "http://localhost:4502/libs/cq/core/content/welcome.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:41 -0400 "GET / HTTP/1.1" 302 - "http://localhost:4502/libs/wcm/core/content/siteadmin.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:41 -0400 "GET /index.html HTTP/1.1" 302 - "http://localhost:4502/libs/wcm/core/content/siteadmin.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"
192.168.1.101 - admin 13/Sep/2013:00:03:41 -0400 "GET /libs/cq/core/content/welcome.html HTTP/1.1" 200 8662 "http://localhost:4502/libs/wcm/core/content/siteadmin.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36"

 

request.log - 

13/Sep/2013:00:16:42 -0400 [74] -> GET /libs/cq/security/widgets/themes/default.js HTTP/1.1
13/Sep/2013:00:16:43 -0400 [71] <- 304 - 1004ms
13/Sep/2013:00:16:43 -0400 [75] -> GET /libs/cq/tagging/widgets/themes/default.css HTTP/1.1
13/Sep/2013:00:16:43 -0400 [70] <- 304 - 1185ms
13/Sep/2013:00:16:43 -0400 [76] -> GET /libs/cq/tagging/widgets/themes/default.js HTTP/1.1
13/Sep/2013:00:16:43 -0400 [69] <- 304 - 2640ms
13/Sep/2013:00:16:43 -0400 [77] -> GET /libs/cq/search/widgets/themes/default.css HTTP/1.1
13/Sep/2013:00:16:43 -0400 [73] <- 304 - 964ms
13/Sep/2013:00:16:43 -0400 [78] -> GET /libs/cq/search/widgets/themes/default.js HTTP/1.1
13/Sep/2013:00:16:43 -0400 [72] <- 304 - 1320ms
13/Sep/2013:00:16:43 -0400 [79] -> GET /libs/dam/widgets/themes/default.css HTTP/1.1
13/Sep/2013:00:16:44 -0400 [78] <- 304 - 461ms
13/Sep/2013:00:16:44 -0400 [80] -> GET /libs/dam/widgets/themes/default.js HTTP/1.1
13/Sep/2013:00:16:44 -0400 [77] <- 304 - 656ms
13/Sep/2013:00:16:44 -0400 [75] <- 304 - 1004ms
13/Sep/2013:00:16:44 -0400 [76] <- 304 - 866ms
13/Sep/2013:00:16:44 -0400 [74] <- 304 - 1534ms
13/Sep/2013:00:16:44 -0400 [80] <- 304 - 233ms
13/Sep/2013:00:16:44 -0400 [79] <- 304 - 602ms
13/Sep/2013:00:16:44 -0400 [81] -> GET /libs/wcm/core/content/damadmin.ico HTTP/1.1
13/Sep/2013:00:16:44 -0400 [82] -> GET / HTTP/1.1
13/Sep/2013:00:16:44 -0400 [82] <- 302 - 3ms
13/Sep/2013:00:16:44 -0400 [81] <- 200 image/vnd.microsoft.icon 8ms
13/Sep/2013:00:16:44 -0400 [83] -> GET /index.html HTTP/1.1
13/Sep/2013:00:16:44 -0400 [83] <- 302 - 2ms
13/Sep/2013:00:16:44 -0400 [84] -> GET /libs/cq/core/content/welcome.html HTTP/1.1
13/Sep/2013:00:16:49 -0400 [85] -> GET /libs/cq/core/content/welcome/welcome.css HTTP/1.1
13/Sep/2013:00:16:49 -0400 [85] <- 304 - 4ms
13/Sep/2013:00:16:49 -0400 [86] -> GET /etc/designs/default/0.gif HTTP/1.1
13/Sep/2013:00:16:49 -0400 [86] <- 304 - 4ms
13/Sep/2013:00:16:49 -0400 [87] -> GET /libs/cq/core/content/welcome/images/sprite.png HTTP/1.1
13/Sep/2013:00:16:49 -0400 [87] <- 404 text/html 45ms
13/Sep/2013:00:16:52 -0400 [84] <- 200 text/html; charset=utf-8 7997ms

 

Kindly let me know solution for this.