Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM Eclipse Dev Tools Install Bundle Failing (MAC -Eclipse -AEM6.5.4 - Dev-Tools -WKND Project)

rajakumare1
Level 2
Level 2

Hi, I  am leaning AEM and  I completed the local setup with AEM DEv Toold in Eclipse as mentioned in the wknd guide.

 

The content and apps folder are syncing correctly but the core bundle is not syncing when I make a change. It is throwing the below error. Can anyone please help. Thanks!!

 

Failed installing bundle : Unable to install/update bundle from dir /Users/b25838/Eclipseworkspaces/AEM-WKND/aem-guides-wknd/core/target/classes : Unable to resolve aem-guides-wknd.core [588](R 588.56): missing requirement [aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0)))]

Unable to install/update bundle from dir /Users/b25838/Eclipseworkspaces/AEM-WKND/aem-guides-wknd/core/target/classes : Unable to resolve aem-guides-wknd.core [588](R 588.56): missing requirement [aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0)))]

4 Replies
Kiran_Vedantam
Community Advisor
Community Advisor

Hi @rajakumare1,

 

As you can see the error, there is a dependency version mismatch. Check this bundle com.day.cq.search installed in your local system and upgrade if needed.

 

Check my comments here on how to do it.

 

Hope this helps.

 

Thanks,

Kiran Vedantam.

rajakumare1
Level 2
Level 2
Hi How do I find the correct bundle. When I do a clean install I see that correct versions are selected to install teh core bundle.
Kiran_Vedantam
Community Advisor
Community Advisor
Hi, pls go to your pom.xml and check the version. Also check your uberjar version. It should be the same as your AEM instance
Anudeep_Garnepudi
Community Advisor
Community Advisor

@rajakumare1 

Check the version of your uber.jar and your AEM version are same or not.