Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

AEM Core Form Container only sending Mail in ‘View as published’

Avatar

Level 2

When trying to submit a container that has the Action Type selected as ‘Mail’, and then viewing it as published from the editor, the mail gets successfully sent to the email I specified in the authoring dialog. 

However, when I visit the actual published page and try to submit the same mail, it doesn’t send. I will note that the published version of my page has a redirected, shortened URL, so not sure if that would cause an issue. I also have the Day CQ Mail Service SMTP address configured in the console. 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@dms879090 : As you confirmed that , from your author server  you are able to send , the same is failing  from publish server even though you have your SMTP configuration in place.

1) May be you can check the SMTP server and Port number you are able connect from the publish server or not 

2)There will be error logged into the logs. You can post the error here.

 

Thanks,

Siva

Thanks,
Siva

View solution in original post

1 Reply

Avatar

Correct answer by
Community Advisor

@dms879090 : As you confirmed that , from your author server  you are able to send , the same is failing  from publish server even though you have your SMTP configuration in place.

1) May be you can check the SMTP server and Port number you are able connect from the publish server or not 

2)There will be error logged into the logs. You can post the error here.

 

Thanks,

Siva

Thanks,
Siva