Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM Communities Using OOTB comments Component. Performance issues

snbaem
Community Advisor
Community Advisor

Hello All,

 

I am using OOTB comments component by pointing a component to "social/commons/components/hbs/comments" for the sling:resourceSuperType property.

On loading the page, I see the comments and can make comments and replies and so on. Using MSRP and Solr for UGC data.

However, for the page/s where the comments component is included The page prints the header and stops/keeps loading (blank remaining page) for 2-3 seconds before loading the comments component and other contents.

I checked the network tab behavior and after the stop the following scripts are loaded

http://localhost:4503/etc.clientlibs/clientlibs/social/commons/scf.css

http://localhost:4503/etc.clientlibs/clientlibs/social/hbs/tally/voting.css

http://localhost:4503/etc.clientlibs/clientlibs/social/hbs/subscriptions.css 

snbaem_0-1628195953470.png

Not sure where the delay is. 

 

There is nothing custom at the moment when I try this in my local. When I do not include the comments component on the page, it loads fine/fast. 

 

We are facing performance issues for pages with comments components for AEM 6.5.8 (In an effort to upgrade from 6.2) No such issue in AEM 6.2 and comments based pages are live and fine..

 

1. Has anyone faced any similar issue related to comments or any other HBS based component?

 

cc @kautuk_sahni (May possibly need your help here too 🙂 )

 

Note: In AEM 6.2 we have extended the backend too still the performance is not affected, and for AEM 658, I just pointed it to OOTB component to rule out any custom interventions and seeing performance issues for the component.

2. Other may be relevant question: Are there any Communities based lucene or Solr/Mongo indexes that must be present in AEM 65 for better performances? 

 

It appears with increasing comments on the page the slowness increases. So my question goes back to any index that needs to be added to Solr/Mongo or anywhere else..?

1 Accepted Solution
Bimmi_Soi
Correct answer by
Community Advisor
Community Advisor

Hi @snbaem ,

 

I believe you should raise a Adobe ticket as this is a weird issue as you are facing performance issues for pages with comments components for AEM 6.5.8 and those are working fine in  AEM 6.2.

 

Thanks

View solution in original post

2 Replies
Bimmi_Soi
Correct answer by
Community Advisor
Community Advisor

Hi @snbaem ,

 

I believe you should raise a Adobe ticket as this is a weird issue as you are facing performance issues for pages with comments components for AEM 6.5.8 and those are working fine in  AEM 6.2.

 

Thanks

View solution in original post

snbaem
Community Advisor
Community Advisor
Thank you @Bimmi_Soi I agree, we have started an effort on that too. I just put out a question here too in case someone has faced this or has some perspective around this.