Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM authoring instances are running too slow after few days of server start (in CQ5.6.1 version with service pack 2)

dragon2A
Level 6
Level 6

Hi Friends,

We are facing slowness in the AEM authoring instances.. when ever the code cache went to to more than 90%, then only we are seeing this problem.  Please take a look at the screenshot . 

one more observation from that memory usage  old gen is also :99%. when we tried to looked into 2000 opened files in the server all are related to the AEM files. 

Is there any way to clear code cache / ps old gen without restarting the server. 

What are the JVM parameters I should use to aviod this kind of problems?.

Its urgent.

 

Thanks in Advance. 

2 Replies
Jörg_Hoh
Employee
Employee

Hi,

when an instance is getting slow after a few days (and after restart everything is fine again), it's most likely a memory (heap) problem, likely you either have a memory leak or you application sometimes consumes more memory (in normal operation), for which the configuration isn't prepared for.

So please check the garbage collection data (you hopefully do have verbose GC enabled).

Jörg

dragon2A
Level 6
Level 6

Hi,

We are in a process of changing JVM parameters . Identified one is code cache size in 50MB . It is reaching to 90% within a week. We are planning to increase that and planning to change the  GC type. Hopefully that will solves our problem. 

I will keep you posed about improvements. 

 

Thanks Everyone.